Bug 1011712 - bash-completion of subscription-manager environments --<TAB><TAB> is incomplete
bash-completion of subscription-manager environments --<TAB><TAB> is incomplete
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Carter Kozak
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-24 18:40 EDT by John Sefler
Modified: 2014-09-14 20:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:30:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-09-24 18:40:55 EDT
Description of problem:

[root@jsefler-6 ~]# subscription-manager environments --help 
Usage: subscription-manager environments [OPTIONS]

Display the environments available for a user

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --username=USERNAME   username to use when authorizing against the server
  --password=PASSWORD   password to use when authorizing against the server
  --org=ORG_KEY         specify organization for environment list, using
                        organization key
  --serverurl=SERVER_URL
                        server URL in the form of https://hostname:443/prefix
  --insecure            do not check the server SSL certificate against
                        available certificate authorities
[root@jsefler-6 ~]# subscription-manager environments -<TAB><TAB>
-h               --help           --org            --password       --proxy          --proxypassword  --proxyuser      --serverurl 


BANG! Based on the output from subscription-manager environments --help, I expected the list of tab completions to also include:
 --username
 --insecure


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.9.7-1.el6.x86_64
Comment 1 Carter Kozak 2013-10-01 10:12:57 EDT
commit fb64365663bcba7e9ab8d79e5bfcf97b29f87074
Author: ckozak <ckozak@redhat.com>
Date:   Thu Sep 26 09:01:04 2013 -0400

    1011712: add missing environments completion
Comment 4 John Sefler 2013-10-03 14:53:39 EDT
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager bash-completion
subscription-manager-1.9.8-1.el6.x86_64
bash-completion-1.3-7.el6.noarch


[root@jsefler-6 ~]# subscription-manager environments -<TAB>
-h               --password       --serverurl
--help           --proxy          --username
--insecure       --proxypassword  
--org            --proxyuser      
[root@jsefler-6 ~]# subscription-manager environments -


VERIFIED: subscription-manager environments options for --username and --insecure now complete with bash-completion
Comment 5 errata-xmlrpc 2013-11-21 16:30:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.