Bug 1011719 - applesmc: BUG: unable to handle kernel paging request at ffff880322aed005 applesmc_get_entry_by_index
applesmc: BUG: unable to handle kernel paging request at ffff880322aed005 app...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:c093a4c1dc493799e537470daf3...
: Triaged
: 981335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 20:07 EDT by Chris Murphy
Modified: 2013-10-02 02:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: kernel-3.11.2-301.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 21:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (125.13 KB, text/plain)
2013-09-24 20:07 EDT, Chris Murphy
no flags Details
dmesg 3.12.0-0.rc3.git0.1.fc21.x86_64 (123.48 KB, text/plain)
2013-09-30 21:56 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-09-24 20:07:07 EDT
Description of problem:
Booting from Fedora 20 alpha RC4 live CD, received abrt message. Hardware is Apple Macbook Pro 4,1 (2008).

Additional info:
reporter:       libreport-2.1.6
BUG: unable to handle kernel paging request at ffff880322aed005
IP: [<ffffffffa05dd345>] applesmc_get_entry_by_index+0x25/0xf0 [applesmc]
PGD 1fe5067 PUD 0 
Oops: 0000 [#1] SMP 
Modules linked in: b43 coretemp kvm_intel kvm joydev bcma mac80211 uvcvideo snd_hda_codec_realtek applesmc(+) iTCO_wdt cfg80211 iTCO_vendor_support microcode input_polldev snd_hda_intel snd_hda_codec i2c_i801 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hwdep snd_seq bcm5974 btusb hid_appleir snd_seq_device media bluetooth snd_pcm lpc_ich mfd_core rfkill snd_page_alloc snd_timer snd apple_bl soundcore shpchp acpi_cpufreq mperf nfsd auth_rpcgss nfs_acl lockd isofs squashfs btrfs libcrc32c xor zlib_deflate raid6_pq usb_storage nouveau firewire_ohci ata_generic pata_acpi firewire_core crc_itu_t sky2 mxm_wmi wmi i2c_algo_bit ssb drm_kms_helper mmc_core ttm drm i2c_core video sunrpc loop
CPU: 1 PID: 492 Comm: systemd-udevd Not tainted 3.11.0-300.fc20.x86_64 #1
Hardware name: Apple Inc. MacBookPro4,1/Mac-F42C89C8, BIOS    MBP41.88Z.00C1.B03.0802271651 02/27/08
task: ffff880132a407a0 ti: ffff8801343fe000 task.ti: ffff8801343fe000
RIP: 0010:[<ffffffffa05dd345>]  [<ffffffffa05dd345>] applesmc_get_entry_by_index+0x25/0xf0 [applesmc]
RSP: 0018:ffff8801343ffa18  EFLAGS: 00010286
RAX: 0000000026000000 RBX: ffff880322aed000 RCX: ffff8801343ffaf4
RDX: 0000000072000000 RSI: ffffffffa05df06e RDI: 0000000026000000
RBP: ffff8801343ffa38 R08: ffff8801343fe000 R09: ffff880132a6c100
R10: 0000000000000000 R11: 0000000000014180 R12: 0000000026000000
R13: 000000004c000001 R14: ffffffffa05df06e R15: ffff8801343ffa84
FS:  00007f6aac863880(0000) GS:ffff88013fd00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff880322aed005 CR3: 00000001340fa000 CR4: 00000000000007e0
Stack:
 000000000004deef ffffffffffffff10 0000000026000000 0000000000000000
 ffff8801343ffa70 ffffffffa05dd4f1 0000000000000032 0000000000000001
 ffffffffa05df06e ffff880134be3810 ffffffffa05e0660 ffff8801343ffaa8
Call Trace:
 [<ffffffffa05dd4f1>] applesmc_get_lower_bound+0x51/0xa0 [applesmc]
 [<ffffffffa05dd563>] applesmc_get_entry_by_key+0x23/0xc0 [applesmc]
 [<ffffffffa05dd9f9>] applesmc_read_key+0x19/0x70 [applesmc]
 [<ffffffffa05de08f>] applesmc_init_smcreg+0x8f/0x2d0 [applesmc]
 [<ffffffffa05de2e2>] applesmc_probe+0x12/0x30 [applesmc]
 [<ffffffff813f41dc>] platform_drv_probe+0x3c/0x70
 [<ffffffff813f18b2>] ? driver_sysfs_add+0x82/0xb0
 [<ffffffff813f1f77>] driver_probe_device+0x87/0x390
 [<ffffffff813f2280>] ? driver_probe_device+0x390/0x390
 [<ffffffff813f22bb>] __device_attach+0x3b/0x40
 [<ffffffff813eff73>] bus_for_each_drv+0x63/0xa0
 [<ffffffff813f1e78>] device_attach+0x88/0xa0
 [<ffffffff813f11e8>] bus_probe_device+0x98/0xc0
 [<ffffffff813eeeb4>] device_add+0x4c4/0x7a0
 [<ffffffff813f3cb1>] platform_device_add+0xd1/0x2d0
 [<ffffffff813f4430>] platform_device_register_full+0xe0/0x120
 [<ffffffffa05e3000>] ? 0xffffffffa05e2fff
 [<ffffffffa05e3098>] applesmc_init+0x98/0x1000 [applesmc]
 [<ffffffff810020fa>] do_one_initcall+0xfa/0x1b0
 [<ffffffff81052483>] ? set_memory_nx+0x43/0x50
 [<ffffffff810cc58d>] load_module+0x1bbd/0x2660
 [<ffffffff810c8890>] ? store_uevent+0x40/0x40
 [<ffffffff810cd1a6>] SyS_finit_module+0x86/0xb0
 [<ffffffff81652cd9>] system_call_fastpath+0x16/0x1b
Code: 84 00 00 00 00 00 66 66 66 66 90 55 48 63 c7 48 8d 14 40 48 89 e5 41 54 41 89 fc 53 48 8d 1c 90 48 83 ec 10 48 03 1d 03 33 00 00 <80> 7b 05 00 48 89 d8 74 12 48 83 c4 10 5b 41 5c 5d c3 66 0f 1f 
RIP  [<ffffffffa05dd345>] applesmc_get_entry_by_index+0x25/0xf0 [applesmc]
 RSP <ffff8801343ffa18>

Potential duplicate: bug 880645
Comment 1 Chris Murphy 2013-09-24 20:07:13 EDT
Created attachment 802522 [details]
File: dmesg
Comment 2 Chris Murphy 2013-09-24 21:53:51 EDT
This is transient.
Comment 3 Chris Murphy 2013-09-24 22:00:38 EDT
Another potential duplicate: bug 981335.
Comment 4 Josh Boyer 2013-09-25 09:21:03 EDT
*** Bug 981335 has been marked as a duplicate of this bug. ***
Comment 5 Josh Boyer 2013-09-25 15:09:25 EDT
I've emailed the upstream maintainers on this one with you CC'd.  Let's see what they say.
Comment 6 Josh Boyer 2013-09-27 12:28:14 EDT
Added the patch from upstream.
Comment 7 Fedora Update System 2013-09-27 17:41:57 EDT
kernel-3.11.2-201.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.2-201.fc19
Comment 8 Fedora Update System 2013-09-28 21:21:17 EDT
Package kernel-3.11.2-201.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.2-201.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17865/kernel-3.11.2-201.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-09-30 12:27:16 EDT
kernel-3.11.2-301.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.2-301.fc20
Comment 10 Fedora Update System 2013-09-30 21:56:02 EDT
kernel-3.11.2-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Chris Murphy 2013-09-30 21:56:58 EDT
Created attachment 805675 [details]
dmesg 3.12.0-0.rc3.git0.1.fc21.x86_64
Comment 12 Chris Murphy 2013-09-30 21:59:28 EDT
Warning message triggered with 3.12.0-0.rc3.git0.1.fc21.x86_64. But I don't see an Oops. Fixed?

[   10.886016] applesmc: key count changed from 261 to 1174405121
Comment 13 Fedora Update System 2013-10-02 02:35:07 EDT
kernel-3.11.2-301.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.