Bug 1011738 - Creating a new SwitchYard project in JBDS fails - runtime version is not populated when download maven repo is used
Creating a new SwitchYard project in JBDS fails - runtime version is not popu...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Maven Repository, Tooling (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Julian Coleman
Andrej Podhradsky
: Reopened
: 1040898 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 22:41 EDT by Len DiMaggio
Modified: 2014-06-16 19:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
If you try to create a new SwitchYard project in JBoss Developer Studio it fails because the runtime version is now populated when the downloaded Maven repository is used. This is because the runtime version field is not populated when creating the project so here is nothing against which the project can be compiled. To work around this, manually enter "1.1.0.M3-redhat-1" as the SwitchYard runtime when creating a new SwitchYard project.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Maven repo - downloaded repo (2.21 KB, application/xml)
2013-09-24 22:45 EDT, Len DiMaggio
no flags Details
maven repo (2.07 KB, application/xml)
2013-09-24 22:46 EDT, Len DiMaggio
no flags Details
Screenshot - download maven repo (50.81 KB, image/png)
2013-09-25 08:57 EDT, Len DiMaggio
no flags Details
Screenshot - online maven repo (51.43 KB, image/png)
2013-09-25 08:58 EDT, Len DiMaggio
no flags Details
Nick's suggested settings.xml (2.61 KB, application/xml)
2013-09-25 10:13 EDT, Len DiMaggio
no flags Details
Screenshot (196.56 KB, image/png)
2013-12-13 14:54 EST, Len DiMaggio
no flags Details
Screenshot when the problem is resolved (69.05 KB, image/png)
2013-12-16 21:24 EST, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1738 Critical Closed Add support for configuring SwitchYard version using runtime components 2016-11-21 15:04 EST
JBoss Issue Tracker SWITCHYARD-1896 Critical Closed Creation of new SwitchYard project in JBDS fails! (Exception: Error resolving version range) 2016-11-21 15:04 EST

  None (edit)
Description Len DiMaggio 2013-09-24 22:41:48 EDT
Description of problem:

Using the downloaded 8.8GB maven repo (http://dev138.mw.lab.eng.bos.redhat.com/candidate/soa-6.0.0-ER3/ip-6.0.0.ER3-redhat-1-repo-all.zip) and a settings.xml that only refers to this repo and a local EAP repo (see attachment), I'm able to build SwitchYard quickstarts packaged with ER3 (http://dev138.mw.lab.eng.bos.redhat.com/candidate/soa-6.0.0-ER3/jboss-eap-6.0.0.fsw.ci-installer.jar).

However, using the same repo with JBDS 7.0.0 and JBDS-IS 7.0.0.Beta3 (http://www.qa.jboss.com/binaries/RHDS/updates/integration/kepler/integration-stack/aggregate/7.0.0.Beta3/), if I create a new SwitchYard project in JBDS (selecting all defaults), I'm seeing these errors:

Failure to find org.switchyard:switchyard-plugin:pom: in http://repository.jboss.org/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository has elapsed or updates are forced

Project build error: 'dependencies.dependency.version' for org.switchyard:switchyard-api:jar is missing.

If I use a settings.xml that references: https://repository.jboss.org/nexus/content/repositories/releases - I am able to create a new project in JBDS with JBDS-IS, but the quickstarts then fail to build from the CLI.

Version-Release number of selected component (if applicable):
ER3

How reproducible:
100%

Steps to Reproduce:
1. See the attached settings.xml 
2. With the downloaded maven repo, attempt to create a new SY project in JBDS
3. With the repository.jboss.org maven repo, attempt to build a SY quickstart

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-09-24 22:45:19 EDT
Created attachment 802535 [details]
Maven repo - downloaded repo
Comment 2 Len DiMaggio 2013-09-24 22:46:13 EDT
Created attachment 802536 [details]
maven repo
Comment 3 Jiri Pechanec 2013-09-25 01:35:33 EDT
The problem is that Runtime Version field is not populated when creating the project so then there is nothing against what the project can be compiled.

There are exceptions in the terminal which are probably related to the problem

Exception in thread "pool-395-thread-1" Exception in thread "pool-394-thread-1" org.eclipse.swt.SWTException: Invalid thread access
        at org.eclipse.swt.SWT.error(SWT.java:4397)
        at org.eclipse.swt.SWT.error(SWT.java:4312)
        at org.eclipse.swt.SWT.error(SWT.java:4283)
        at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
        at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
        at org.eclipse.swt.widgets.Label.setText(Label.java:578)
        at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
        at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
        at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
        at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
        at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
        at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
        at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
        at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
        at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:724)
org.eclipse.swt.SWTException: Invalid thread access
        at org.eclipse.swt.SWT.error(SWT.java:4397)
        at org.eclipse.swt.SWT.error(SWT.java:4312)
        at org.eclipse.swt.SWT.error(SWT.java:4283)
        at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
        at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
        at org.eclipse.swt.widgets.Label.setText(Label.java:578)
        at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
        at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
        at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
        at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
        at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
Exception in thread "pool-392-thread-2"         at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
        at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
        at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
        at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:724)
org.eclipse.swt.SWTException: Invalid thread access
        at org.eclipse.swt.SWT.error(SWT.java:4397)
        at org.eclipse.swt.SWT.error(SWT.java:4312)
        at org.eclipse.swt.SWT.error(SWT.java:4283)
        at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
        at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
        at org.eclipse.swt.widgets.Label.setText(Label.java:578)
        at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
        at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
        at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
        at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
        at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
        at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
        at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
        at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
        at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:724)
Exception in thread "pool-392-thread-3" org.eclipse.swt.SWTException: Invalid thread access
        at org.eclipse.swt.SWT.error(SWT.java:4397)
        at org.eclipse.swt.SWT.error(SWT.java:4312)
        at org.eclipse.swt.SWT.error(SWT.java:4283)
        at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
        at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
        at org.eclipse.swt.widgets.Label.setText(Label.java:578)
        at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
        at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
        at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
        at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
        at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
        at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
        at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
        at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
        at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:724)
Comment 4 Len DiMaggio 2013-09-25 06:35:48 EDT
Thanks Jirka - I missed that during the project creation!
Comment 5 Len DiMaggio 2013-09-25 06:55:30 EDT
The eclipse log shows:


[ldimaggi@ldimaggi .metadata]$ cat .log
!SESSION 2013-09-25 06:46:19.755 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_25
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product com.jboss.jbds.product.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -product com.jboss.jbds.product.product

!ENTRY org.switchyard.tools.ui 4 -1 2013-09-25 06:48:08.420
!MESSAGE Error loading available SwitchYard capabilities.
!STACK 0
java.lang.reflect.InvocationTargetException
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup$4.run(SwitchYardSettingsGroup.java:239)
	at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
	at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
	at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:1028)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.initControls(SwitchYardSettingsGroup.java:230)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.<init>(SwitchYardSettingsGroup.java:169)
	at org.switchyard.tools.ui.wizards.ProjectConfigurationWizardPage.createControl(ProjectConfigurationWizardPage.java:179)
	at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:174)
	at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:736)
	at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:608)
	at org.eclipse.jface.window.Window.create(Window.java:432)
	at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1104)
	at org.eclipse.ui.internal.navigator.wizards.WizardShortcutAction.run(WizardShortcutAction.java:95)
	at org.eclipse.jface.action.Action.runWithEvent(Action.java:499)
	at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
	at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
	at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1392)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3742)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3363)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:138)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:610)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Caused by: org.eclipse.core.runtime.CoreException: Error resolving version range
	at org.switchyard.tools.ui.M2EUtils.resolveVersionRange(M2EUtils.java:188)
	at org.switchyard.tools.ui.M2EUtils.resolveSwitchYardVersionRange(M2EUtils.java:156)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.populateRuntimeVersionsList(SwitchYardSettingsGroup.java:263)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.access$5(SwitchYardSettingsGroup.java:262)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup$4.run(SwitchYardSettingsGroup.java:237)
	... 42 more
Caused by: org.eclipse.swt.SWTException: Invalid thread access
	at org.eclipse.swt.SWT.error(SWT.java:4397)
	at org.eclipse.swt.SWT.error(SWT.java:4312)
	at org.eclipse.swt.SWT.error(SWT.java:4283)
	at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
	at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
	at org.eclipse.swt.widgets.Label.setText(Label.java:578)
	at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
	at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
	at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
	at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
	at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
	at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
	at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
	at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:724)
Root exception:
org.eclipse.core.runtime.CoreException: Error resolving version range
	at org.switchyard.tools.ui.M2EUtils.resolveVersionRange(M2EUtils.java:188)
	at org.switchyard.tools.ui.M2EUtils.resolveSwitchYardVersionRange(M2EUtils.java:156)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.populateRuntimeVersionsList(SwitchYardSettingsGroup.java:263)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.access$5(SwitchYardSettingsGroup.java:262)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup$4.run(SwitchYardSettingsGroup.java:237)
	at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
	at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
	at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:1028)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.initControls(SwitchYardSettingsGroup.java:230)
	at org.switchyard.tools.ui.common.SwitchYardSettingsGroup.<init>(SwitchYardSettingsGroup.java:169)
	at org.switchyard.tools.ui.wizards.ProjectConfigurationWizardPage.createControl(ProjectConfigurationWizardPage.java:179)
	at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:174)
	at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:736)
	at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:608)
	at org.eclipse.jface.window.Window.create(Window.java:432)
	at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1104)
	at org.eclipse.ui.internal.navigator.wizards.WizardShortcutAction.run(WizardShortcutAction.java:95)
	at org.eclipse.jface.action.Action.runWithEvent(Action.java:499)
	at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
	at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
	at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1392)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3742)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3363)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:138)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:610)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Caused by: org.eclipse.swt.SWTException: Invalid thread access
	at org.eclipse.swt.SWT.error(SWT.java:4397)
	at org.eclipse.swt.SWT.error(SWT.java:4312)
	at org.eclipse.swt.SWT.error(SWT.java:4283)
	at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
	at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
	at org.eclipse.swt.widgets.Label.setText(Label.java:578)
	at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
	at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
	at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
	at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
	at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
	at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
	at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
	at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:724)
!SUBENTRY 1 org.switchyard.tools.ui 4 0 2013-09-25 06:48:08.422
!MESSAGE Error resolving version range
!STACK 0
org.eclipse.swt.SWTException: Invalid thread access
	at org.eclipse.swt.SWT.error(SWT.java:4397)
	at org.eclipse.swt.SWT.error(SWT.java:4312)
	at org.eclipse.swt.SWT.error(SWT.java:4283)
	at org.eclipse.swt.widgets.Widget.error(Widget.java:481)
	at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:419)
	at org.eclipse.swt.widgets.Label.setText(Label.java:578)
	at org.eclipse.jface.wizard.ProgressMonitorPart.updateLabel(ProgressMonitorPart.java:367)
	at org.eclipse.jface.wizard.ProgressMonitorPart.subTask(ProgressMonitorPart.java:358)
	at org.eclipse.jface.wizard.WizardDialog$4.subTask(WizardDialog.java:707)
	at org.eclipse.core.runtime.ProgressMonitorWrapper.subTask(ProgressMonitorWrapper.java:156)
	at org.eclipse.core.runtime.SubProgressMonitor.subTask(SubProgressMonitor.java:174)
	at org.eclipse.m2e.core.internal.embedder.AbstractTransferListenerAdapter.transferCompleted(AbstractTransferListenerAdapter.java:104)
	at org.eclipse.m2e.core.internal.embedder.ArtifactTransferListenerAdapter.transferFailed(ArtifactTransferListenerAdapter.java:64)
	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:677)
	at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:724)

!ENTRY org.eclipse.osgi 2 1 2013-09-25 06:48:23.250
!MESSAGE NLS unused message: label_moveDefault in: org.switchyard.tools.ui.editor.messages
Comment 6 Keith Babo 2013-09-25 07:59:26 EDT
Are you entering a runtime version when you create the project?
Comment 8 Len DiMaggio 2013-09-25 08:57:50 EDT
Created attachment 802841 [details]
Screenshot - download maven repo
Comment 9 Len DiMaggio 2013-09-25 08:58:39 EDT
Created attachment 802842 [details]
Screenshot - online maven repo
Comment 10 Len DiMaggio 2013-09-25 10:12:42 EDT
Using Nick's suggested settings.xml resolves the SwitchYard runtime pulldown issue, but this error remains when a new SwitchYard project is created:

Failure to find org.switchyard:switchyard-plugin:pom: in http://repository.jboss.org/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository has elapsed or updates are forced	

Looking at the repo, I'm only seeing these artifacts being created:

tree /opt/local/repository
/opt/local/repository
└── org
    └── switchyard
        ├── switchyard-api
        │   └── resolver-status.properties
        └── switchyard-plugin
            └── switchyard-plugin-.pom.lastUpdated

4 directories, 2 files
Comment 11 Len DiMaggio 2013-09-25 10:13:35 EDT
Created attachment 802874 [details]
Nick's suggested settings.xml
Comment 12 Keith Babo 2013-09-25 10:36:39 EDT
Try a mvn -U to purge the resolution status, which should attempt resolution again.  An earlier failure to resolve these artifacts could be the culprit here.  

Also, what value are you using for the runtime version when you create your project?  There should be a property definition for "switchyard.version" in your pom.xml - what's the value of that property?  Does the version specified there exist in your Maven repo?
Comment 13 Rob Cernich 2013-09-25 10:37:56 EDT
Len, repeating Keith's question, does everything work if you manually enter a runtime version, e.g. 1.1.0.M3-redhat-1.

The tools will attempt to populate the drop list using the repository indices, but there are instances when this will not occur (e.g. when creating a project in an empty workspace).  In those instances, a default version is specified (e.g. 1.0.0.Final), but that version probably doesn't exist in your local repository.

Either way, please try entering a valid version for the runtime in the wizard.
Comment 14 Len DiMaggio 2013-09-25 10:39:47 EDT
Correction - to see the error in JBDS:

    Steps to Reproduce:
    1. With the downloaded maven repo, attempt to create a new SY project in JBDS
Comment 15 Len DiMaggio 2013-09-25 11:19:28 EDT
OK - with ER3 - manually entering 1.1.0.M3-redhat-1 as the runtime allowed the new SwitchYard project to be created - using the settings.xml that Nick suggested.
Comment 16 Len DiMaggio 2013-09-25 12:01:29 EDT
To recap, for Beta, users must:

* Use the download repo plus the techpreview repo

* Manually enter "1.1.0.M3-redhat-1" as the SwitchYard runtime when creating a new SwitchYard project
Comment 17 Anne-Louise Tangring 2013-09-26 08:48:52 EDT
Important to note that we make sure the right version is used in the string. If we update to ER4, this will be a different version.
Comment 19 Len DiMaggio 2013-09-27 09:39:25 EDT
One more thing being seen now:

The first time a new SwitchYard project is created, if the user enters 1.1.0.M3-redhat-1 into the blank runtime field, project is created.

Then, if a second project is created, 1.0.0.Final is auto-filled into the field.
Comment 20 Rob Cernich 2013-09-27 09:58:21 EDT
(In reply to Len DiMaggio from comment #19)
> One more thing being seen now:
> 
> The first time a new SwitchYard project is created, if the user enters
> 1.1.0.M3-redhat-1 into the blank runtime field, project is created.
> 
> Then, if a second project is created, 1.0.0.Final is auto-filled into the
> field.

Hey Len, I think a separate issue should be created for this enhancement, e.g.:

Value for runtime version should be persisted between dialog invocations.

and/or

Use preferences to initialize default runtime version.
Comment 22 JBoss JIRA Server 2013-10-07 08:59:43 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1738

pushed
Comment 25 Andrej Podhradsky 2013-12-12 08:36:08 EST
*** Bug 1040898 has been marked as a duplicate of this bug. ***
Comment 26 Andrej Podhradsky 2013-12-12 08:42:25 EST
The same problem occurs with FSW 6.0.0.ER7 local repo. The runtime version is blank and finish button is disabled => cannot create a switchyard project.
Comment 27 Len DiMaggio 2013-12-13 14:53:50 EST
I am seeing the error with:

JBDS 7.1.0.GA
JBDSIS - http://www.qa.jboss.com/binaries/RHDS/updates/development/kepler/integration-stack/aggregate/7.0.0.CR1/

See the attached screenshot. The runtime library version is blank and cannot be filled in.
Comment 28 Len DiMaggio 2013-12-13 14:54:38 EST
Created attachment 836485 [details]
Screenshot
Comment 30 Len DiMaggio 2013-12-16 21:24:34 EST
Created attachment 837514 [details]
Screenshot when the problem is resolved
Comment 31 Andrej Podhradsky 2014-01-21 09:22:53 EST
This has been already fixed in JBDS-IS 7.0.0.CR2
Comment 32 JBoss JIRA Server 2014-06-16 19:51:58 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1738 to Closed
Comment 33 JBoss JIRA Server 2014-06-16 19:53:30 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1896 to Closed

Note You need to log in before you can comment on or make changes to this bug.