Bug 1011761 - NFS crashed
NFS crashed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.4.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: santosh pradhan
:
Depends On: 958043 959190
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 01:47 EDT by santosh pradhan
Modified: 2014-04-17 09:14 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 959190
Environment:
Last Closed: 2014-04-17 09:14:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-25 01:57:47 EDT
REVIEW: http://review.gluster.org/5996 (gNFS: avoid double fd unref in opendir) posted (#1) for review on release-3.4 by Santosh Pradhan (spradhan@redhat.com)
Comment 2 Anand Avati 2013-09-25 02:02:30 EDT
REVIEW: http://review.gluster.org/5996 (gNFS: avoid double fd unref in opendir) posted (#2) for review on release-3.4 by Santosh Pradhan (spradhan@redhat.com)
Comment 3 Anand Avati 2013-09-25 02:50:29 EDT
COMMIT: http://review.gluster.org/5996 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 22e982e31bc232f3d9597a41f49e715428e010ce
Author: Santosh Kumar Pradhan <spradhan@redhat.com>
Date:   Wed Sep 25 11:24:28 2013 +0530

    gNFS: avoid double fd unref in opendir
    
    Noticed that the fd_unref was called on the fd regardless of the return
    value at nfs3svc_opendir_readdir_cbk(), hence removing an extra unref in
    the negative case in nfs_inode_opendir_cbk, which fixes the spurious
    fd_unref().
    
    Back port of: http://review.gluster.org/4943 (Rajesh Amaravathi)
    
    Change-Id: Ibddf487c7890407d01befedd65eefb10cb9c989f
    BUG: 1011761
    Signed-off-by: Santosh Kumar Pradhan <spradhan@redhat.com>
    Reviewed-on: http://review.gluster.org/5996
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Niels de Vos 2014-04-17 09:14:36 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.