Bug 1011798 - No prompt information after changes admin/root password in rescue/single mode
No prompt information after changes admin/root password in rescue/single mode
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 03:24 EDT by wanghui
Modified: 2016-02-10 14:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-17 08:39:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wanghui 2013-09-25 03:24:37 EDT
Description of problem:
After auto-install ovirt-node-iso-3.1.0-0.999.999.20130925040411gitdd3a8bd.756.fc18.iso, entering rescue/single mode to change the admin/root password. There is no prompt information after changes admin/root password. The output is as follows.
--------------------------------------------------------------------
#/usr/libexec/ovirt-config-password

 Password Configuration

Enter ? for help.
> set_admin_password
 Password Configuration

System Administrator (admin):

Changing password for user 'admin'.
New password:
Retype new Password:
>
> set_root_password

 Password Configuration

System Administrator (root):

Changing password for user 'root'.
New password:
Retype new Password:
>                         #press "Enter"
 Password Configuration

System Administrator (root):

Changing password for user 'root'.
New password:
---------------------------------------------------------------

After change the password succeed, there is no prompt information. And if you press "Enter", it will redo the before operation.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.999.20130925040411gitdd3a8bd.756.fc18.iso

How reproducible:
100%

Steps to Reproduce:


Actual results:


Expected results:
1.There should give a friendly prompt information to indicate changes password succeed.
2.It should no redo the before operation when press "Enter".

Additional info:
Comment 1 Sandro Bonazzola 2014-03-04 04:24:10 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 2 Sandro Bonazzola 2014-05-08 09:55:02 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 3 Sandro Bonazzola 2014-10-17 08:39:51 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.