Bug 1011799 - httpie-0.7.2 is available
Summary: httpie-0.7.2 is available
Alias: None
Product: Fedora
Classification: Fedora
Component: httpie
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Rick Elrod
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2013-09-25 07:28 UTC by Upstream Release Monitoring
Modified: 2014-05-12 03:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Last Closed: 2014-05-12 03:17:03 UTC
Type: ---

Attachments (Terms of Use)

Description Upstream Release Monitoring 2013-09-25 07:28:28 UTC
Latest upstream release: 0.7.2
Current version/release in Fedora Rawhide: 0.6.0-5.fc20
URL: https://pypi.python.org/packages/source/h/httpie/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:

Comment 1 Fedora Update System 2013-09-28 23:22:30 UTC
httpie-0.7.2-1.fc19 has been submitted as an update for Fedora 19.

Comment 2 Fedora Update System 2013-09-28 23:46:49 UTC
httpie-0.7.2-1.fc18 has been submitted as an update for Fedora 18.

Comment 3 Fedora Update System 2013-09-29 00:09:55 UTC
httpie-0.7.2-1.el6 has been submitted as an update for Fedora EPEL 6.

Comment 4 Fedora Update System 2013-09-29 18:19:38 UTC
Package httpie-0.7.2-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing httpie-0.7.2-1.el6'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 5 Ralph Bean 2013-10-09 13:18:18 UTC
It looks like httpie-0.7.2 requires python-requests-2.0.0 or later.

This is problematic because we only have that version of requests in rawhide at this point.

Comment 6 Rick Elrod 2013-10-10 00:36:42 UTC
I have a patch to make it look for older python-requests (it doesn't appear to actually /need/ 2.0.0 to work.) I will push this to testing hopefully tomorrow. I'm a bit behind on my package maintenance, planning on fully catching up this weekend. School keeps me too busy. :(

Thanks for letting me know.

Note You need to log in before you can comment on or make changes to this bug.