Bug 10118 - rpc.mountd memory leak
Summary: rpc.mountd memory leak
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-10 23:35 UTC by william.r.snyder.iii
Modified: 2007-04-18 16:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 11:23:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description william.r.snyder.iii 2000-03-10 23:35:18 UTC
We are running Red Hat Linux release 6.1, kernel 2.2.12-20smp on i686.
The rpc.mountd dameon begins to use up our system's memory until it is
beyond 100MB of ram used.  Usually at this point the external machines
trying to mount the machine are unable to connect.

Our temporary fix was to kill the daemon every 3 hours and restart it.
The memory still grows but the kill/restart allows for the remote machines
to mount and umount cleanly.  Some of test machines go up and down 10-15
times and hour.  It seems that the rpc.mountd is not cleaning up memory
properly.

Thanks Bill Snyder
       Software Engineer
       Intel Corporation

Comment 1 Alex Lancaster 2000-04-18 22:41:59 UTC
We have observed similar behaviour with our Red Hat 6.2 LAN (using the
out-of-the-box kernel-2.2.14-5.0), we have a i686 with SMP on 550 MHz PIII.

Comment 2 Cristian Gafton 2000-08-09 02:35:24 UTC
assigned to johnsonm

Comment 3 Steve Dickson 2002-12-20 11:23:50 UTC
Unable to reproduce in current release


Note You need to log in before you can comment on or make changes to this bug.