Bug 1011821 - "SLF4J: The following loggers will not work" during EAP 6.2.0.ER3 startup
Summary: "SLF4J: The following loggers will not work" during EAP 6.2.0.ER3 startup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: CR1
: EAP 6.2.0
Assignee: James Perkins
QA Contact: Nikoleta Hlavickova
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: 1026295
TreeView+ depends on / blocked
 
Reported: 2013-09-25 08:12 UTC by Jitka Kozana
Modified: 2015-02-20 10:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-15 16:15:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker WFLY-2425 0 Minor Resolved Use forked version of slf4j to fix concurrency issue with static binding 2017-01-30 15:15:35 UTC

Description Jitka Kozana 2013-09-25 08:12:43 UTC
The following error is sometimes logged during the EAP startup, version EAP 6.2.0.ER3:

02:56:13,466 ERROR [stderr] (MSC service thread 1-3) SLF4J: The following loggers will not work because they were created
02:56:13,468 ERROR [stderr] (MSC service thread 1-3) SLF4J: during the default configuration phase of the underlying logging system.
02:56:13,469 ERROR [stderr] (MSC service thread 1-3) SLF4J: See also http://www.slf4j.org/codes.html#substituteLogger
02:56:13,476 ERROR [stderr] (MSC service thread 1-3) SLF4J: org.apache.ws.security.WSSConfig

See the startup log here:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-manu-acceptance-startup-RHEL-dev/13/jdk=java16_default,label=RHEL6_x86_64/artifact/target/manu-reports/units/manu.testsuite.eap6.acceptance.startup.CleanStartupAcceptanceEap6/jboss-eap-6.2/domain/server-one/server.log

Seen on RHEL, solaris, windows.

Comment 1 James Perkins 2013-10-04 15:15:56 UTC
Is this by chance reproducible? I can't seem to get the message to appear.

Comment 2 Jitka Kozana 2013-10-07 12:17:13 UTC
This was seen on ER4 build as well.

Reproducible: around 40% of all clean startups of EAP have this error in logs.
Just unzip EAP, start domain and observe the error.
Or start two EAP's with standalone-ha or standalone-full-ha, ... profile on one machine with different ports.

Comment 3 Pavel Janousek 2013-10-07 12:23:55 UTC
The issue affects also RPM based installations.

Clean start/stop is one of the requirements for release, thus proposing this as blocker.

Comment 4 James Perkins 2013-10-07 20:37:57 UTC
This looks like an slf4j-api bug. I'm forking the repo on GitHub and doing up a patch for it.

Comment 5 James Perkins 2013-10-07 22:27:06 UTC
This would be the proposed patch for slf4j https://github.com/jamezp/slf4j/compare/issue176.

Comment 6 James Perkins 2013-10-07 22:28:18 UTC
Adding the slf4j issue http://bugzilla.slf4j.org/show_bug.cgi?id=176

Comment 7 James Perkins 2013-10-22 16:13:32 UTC
This requires a fix in slf4j. The issue linked above was opened in 2010 and doesn't seem to have much movement on it. The patch I've linked to this issue and attached to the slf4j issue should work. If someone wants to maintain a fork of slf4j, then that should fix this issue.

Comment 9 Kyle Lape 2013-10-29 21:26:20 UTC
Based on the error in the server.log (and posted in #c1), all log messages from org.apache.ws.security.WSSConfig will be lost for the life of the JVM since that logger member is static:

54 public class WSSConfig {
55
56     private static final org.apache.commons.logging.Log LOG =
57         org.apache.commons.logging.LogFactory.getLog(WSSConfig.class);

Do we know how many classes this could potentially affect?  It seems pretty risky to me to have potentially any component that uses SLF4J or Apache Commons Logging to lose its logging messages if it's initialized at a certain time.  

This issue may have existed already, but with the increased visibility to our customers, this will likely make some of them uneasy and file a support case and maybe even request a patch for it.

Comment 15 JBoss JIRA Server 2013-11-05 00:05:15 UTC
James Perkins <jperkins@redhat.com> made a comment on jira WFLY-2425

Pull request merged

Comment 16 Jitka Kozana 2013-11-11 13:57:17 UTC
 This issue was verified using the 6.2.0.CR1 preview bits.


Note You need to log in before you can comment on or make changes to this bug.