Bug 1011831 - JBREM000205: Failed to accept a connection: java.nio.channels.ClosedChannelException at server shutdown
JBREM000205: Failed to accept a connection: java.nio.channels.ClosedChannelEx...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Remoting (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER2
: EAP 6.3.0
Assigned To: David M. Lloyd
Jitka Kozana
Russell Dickenson
:
: 1009766 (view as bug list)
Depends On: 1080576
Blocks: eap63-beta-blockers
  Show dependency treegraph
 
Reported: 2013-09-25 04:25 EDT by Jitka Kozana
Modified: 2014-06-28 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A `DEBUG` message from the remoting sugbsystem was incorrectly logged as a `WARN` message during server shutdown. The message logged was similar to the following: ---- 02:46:15,512 WARN [org.jboss.remoting.remote] (Remoting "node1:MANAGEMENT" read-1) JBREM000205: Failed to accept a connection: java.nio.channels.ClosedChannelException ---- As part of an upgrade to the remoting subsystem in this release of JBoss EAP 6, this message has been correctly reclassified as a `DEBUG` level message.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:37:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitka Kozana 2013-09-25 04:25:34 EDT
This exception is sometimes logged on server shutdown:

02:46:15,512 WARN  [org.jboss.remoting.remote] (Remoting "node1:MANAGEMENT" read-1) JBREM000205: Failed to accept a connection: java.nio.channels.ClosedChannelException

See the server log here:

https://jenkins.mw.lab.eng.bos.redhat.com/job/eap-6x-manu-multinode-startup-different-IPs-solaris/jdk=java16_default,label_exp=sol10_sparc64/30/artifact/target/manu-reports/units/manu.testsuite.eap6.acceptance.multinodeStartup.MultinodeStartupDifferentIPs/server.log-standalone-full.xml-server2.log
Comment 1 Jitka Kozana 2013-10-07 08:19:52 EDT
Seen again during EAP 6.2.0.ER4 testing.
Comment 2 Jitka Kozana 2014-01-23 08:38:00 EST
Seen again during EAP 6.2.1.CP.CR1 testing.
Comment 3 David M. Lloyd 2014-01-23 09:22:29 EST
I have an upstream patch to move this message to DEBUG.  It is relevant, perhaps, but an unimportant condition, and not indicative of any real problem.
Comment 4 Rostislav Svoboda 2014-03-04 07:30:27 EST
*** Bug 1009766 has been marked as a duplicate of this bug. ***
Comment 5 Rostislav Svoboda 2014-03-05 07:51:10 EST
Proposing as blocker as discussed on EAP 6 PM meeting March 4.

This is blocking acceptance tests where we have requirement for issue-less startup & shutdown.
Comment 7 Rostislav Svoboda 2014-03-21 06:55:16 EDT
DEBUG level is fine, it's blocker from clean start and shutdown perspective, based on comments no functional issue.

David, please go ahead and grant dev_ack.
Comment 9 Jitka Kozana 2014-04-30 08:33:58 EDT
EAP 6.3.0.ER2, Verified.

Note You need to log in before you can comment on or make changes to this bug.