Bug 1011853 - /etc/sysconfig/nfs sets variables that are not used by the nfs service
/etc/sysconfig/nfs sets variables that are not used by the nfs service
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.1
Assigned To: Yedidyah Bar David
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 04:56 EDT by Yedidyah Bar David
Modified: 2016-02-10 15:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 06:50:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19472 None None None Never
oVirt gerrit 19931 None None None Never

  None (edit)
Description Yedidyah Bar David 2013-09-25 04:56:43 EDT
Description of problem:

conf/nfs.sysconfig.in, which is used to update /etc/sysconfig/nfs,
sets variables that are no longer used in recent fedora nfs-utils
init scripts.

In particular, configuring iptables/firewalld to open nfs access
to the host to serve the ISO domain, does not work, as e.g. mountd
runs with its default port number and not the open opened in iptables.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. run engine-setup, choose to configure an ISO domain
2. run 'ps -ef | grep mountd'

Actual results:

rpc.mountd runs with default options

Expected results:

rpc.mountd should run with '-p 892'

Additional info:
Comment 1 Itamar Heim 2013-09-25 12:05:51 EDT
are they needed by .el6 still?
Comment 2 Itamar Heim 2013-09-27 12:24:30 EDT
flagging storage for their input to this, even if implementation is covered by integration
Comment 3 Yedidyah Bar David 2013-09-29 01:50:25 EDT
(In reply to Itamar Heim from comment #1)
> are they needed by .el6 still?

They are not "needed". In el6, there are e.g. both MOUNTD_PORT and RPCMOUNTDOPTS. In (recent enough) fedora there is only RPCMOUNTDOPTS. So using RPCMOUNTDOPTS works on both.

Why did the people packaging nfs-utils on fedora "went back"? I guess because they wanted to run the various daemons from systemd directly, without going through wrapper scripts. Doing something like
        [ -n "$MOUNTD_PORT" ] \
        && RPCMOUNTDOPTS="$RPCMOUNTDOPTS -p $MOUNTD_PORT"
in /etc/init.d/nfs on el6 is easy, but if you want something similar in systemd, you can't staff it into the service file, which is currently:
EnvironmentFile=-/etc/sysconfig/nfs
ExecStart=/usr/sbin/rpc.mountd $RPCMOUNTDOPTS
you have to make a wrapper script.

That's just a guess, of course, and while I might not agree with the decision to do that, I can understand the reasoning behind it.
Comment 4 Ayal Baron 2013-09-29 08:41:32 EDT
Itamar, I'm not sure what the question here is?
Didi covered the technical side.  I've commented on the patch.
Comment 5 Sandro Bonazzola 2013-10-21 10:09:11 EDT
Included in 3.3.1 beta
Comment 6 Sandro Bonazzola 2013-11-25 06:50:51 EST
oVirt 3.3.1 has been released

Note You need to log in before you can comment on or make changes to this bug.