Bug 1011875 - virsh snapshot-revert requires force parameter
virsh snapshot-revert requires force parameter
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Krempa
Virtualization Bugs
: Upstream
: 1033437 (view as bug list)
Depends On: 1006886
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 06:06 EDT by Xuesong Zhang
Modified: 2014-04-04 16:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1006886
Environment:
Last Closed: 2014-04-04 16:56:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xuesong Zhang 2013-09-25 06:06:38 EDT
This bug is occurred in latest rhel6.5, so clone it to rhel6.5.

But the error message is a little difference, here is the error message in rhel6.5:
# virsh snapshot-create-as a sp1
Domain snapshot sp1 created
# virsh snapshot-revert a sp1
error: revert requires force: Target controller type ide does not match source usb

Version:
libvirt-0.10.2-24.el6.x86_64
qemu-kvm-0.12.1.2-2.402.el6.x86_64
kernel-2.6.32-419.el6.x86_64

+++ This bug was initially created as a clone of Bug #1006886 +++

Description of problem:
The internal snapshot cannot be reverted. It requires a force parameter but it should work without this parameter.

Version-Release number of selected component (if applicable):
upstream, libvirt-1.1.1-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. virsh snapshot-create domain
2. virsh snapshot-revert domain snapshot-id

Actual results:
error: revert requires force: Target device address type none does not match source pci

Expected results:
The snapshot should be reverted successfully without an error message.

--- Additional comment from Peter Krempa on 2013-09-12 06:20:29 EDT ---

Patch posted upstream http://www.redhat.com/archives/libvir-list/2013-September/msg00688.html

--- Additional comment from Peter Krempa on 2013-09-12 10:16:59 EDT ---

http://post-office.corp.redhat.com/archives/rhvirt-patches/2013-September/msg00431.html

--- Additional comment from Shanzhi Yu on 2013-09-15 21:21:54 EDT ---

Verify this bug with package libvirt-1.1.1-5.el7.x86_64
Steps:
1. exist an guest
# virsh list 
 Id    Name                           State
----------------------------------------------------
 9     rhel7qcow2                     running

2. create an snapshot
# virsh snapshot-create rhel7qcow2 

Domain snapshot 1379294046 created
3. revert the snapshot
# virsh snapshot-revert rhel7qcow2 1379294046

Succeed reverting snapshot with no error,so verify this bug.
Comment 1 Peter Krempa 2013-11-22 04:19:21 EST
*** Bug 1033437 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2014-04-04 16:56:53 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.