Bug 101189 - acpid should react to ac_adapter events.
acpid should react to ac_adapter events.
Status: CLOSED DUPLICATE of bug 81142
Product: Red Hat Linux Beta
Classification: Retired
Component: acpid (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-29 17:47 EDT by Aleksey Nogin
Modified: 2014-03-16 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-07-29 17:47:04 EDT
Currently, APM scripts do a lot of useful things when power is switched to/from
AC - laptop mode adjustment, POWER_SERVICES start/stop, cpufreq adjustments,
etc. But with ACPI all of this goes away! Currently, the acpid would correctly
generate proper ac_adapter events (when the appropriate module is loaded), but
there are no configuration files and no scripts that would react to those events.

Please consider adding appropriate scripts and configs, so that ACPI events are
handled as good as APM ones (I understand that many things are different on the
kernel level, but at least the common functionality should be equally supported
and ideally - supported through some shared configs and scripts).

----------

P.S. IMO, the best way to address this is to factor the current apmscript into a
generic part (that probably belongs to initscripts) that knows how to read a
config file (/etc/sysconfig/apmd, but it should probably be renamed) and a part
that only knows how to parse the arguments and apm putput to figure out which
standard function to call./proc/acpi/ac_adapter/AC/state


P.P.S. And to propose something rally crazy - it may be a good idea to have the
generic part be split into initd-style start/stop scripts - this would allow
other packages and end-users to easily add their own scripts without
interfeering with the default ones. Namely, I propose something like:
- on AC on -> off, call all scripts in /etc/sysconfig/power/battery_power/
directory with the "start" argument
- on AC off -> on, call all scripts in /etc/sysconfig/power/battery_power/
directory with the "stop" argument
- on battery low, call all scripts in /etc/sysconfig/power/battery_low/
directory with the "start" argument
- etc.
Comment 1 Bill Nottingham 2003-07-29 18:48:50 EDT

*** This bug has been marked as a duplicate of 81142 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.