Bug 1011892 - Incomplete man page for iconv
Incomplete man page for iconv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1124708
  Show dependency treegraph
 
Reported: 2013-09-25 06:53 EDT by Jakub Prokes
Modified: 2014-10-14 03:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: iconv man page was incomplete Consequence: incomplete documentation Fix: new man page from upstream updates rhel man page Result: updated documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:26:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Prokes 2013-09-25 06:53:15 EDT
Description of problem:
In man page for iconv are not described all options.


Version-Release number of selected component (if applicable):
glibc-common-2.12-1.107.el6.ppc64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Information about '-c' and '-s' switches. Which is described in help.

iconv --help


Additional info:
Comment 3 Peter Schiffer 2014-02-04 12:35:20 EST
In the mean time, you can check out the iconv(1p) man page, which contains description of required options:

-c     Omit any characters that are invalid in the codeset of the input
       file from the output. When  -c  is  not  used,  the  results  of
       encountering  invalid  characters  in  the  input stream (either
       those that are not characters in the codeset of the  input  file
       or  that  have  no corresponding character in the codeset of the
       output file) shall be specified in the system documentation. The
       presence  or  absence  of -c shall not affect the exit status of
       iconv.

-s     Suppress any  messages  written  to  standard  error  concerning
       invalid  characters. When -s is not used, the results of encoun‐
       tering invalid characters in the input stream (either those that
       are  not  valid  characters  in the codeset of the input file or
       that have no corresponding character in the codeset of the  out‐
       put  file)  shall  be specified in the system documentation. The
       presence or absence of -s shall not affect the  exit  status  of
       iconv.
Comment 4 Peter Schiffer 2014-04-22 07:57:53 EDT
There are 2 possible soultions for this bug:

 * update the iconv(1) man page with information from for example iconv(1p)

 * remove iconv(1) man page and keep only iconv(1p) man page, which is far more complete

I would prefer second solution, but functionality described in iconv(1p) man page should be tested against actual implementation of iconv program in RHEL-6.

peter
Comment 5 Jan Chaloupka 2014-06-04 08:03:28 EDT
On Fedora 20 there is no /usr/share/man/man1/iconv.1.gz, only /usr/share/man/man1p/iconv.1p.gz as Peter posted.

How much iconv on rhel6.6 and f20 differ? Can you take a look at it or say what solution is better for your component?
Comment 6 Jan Chaloupka 2014-06-12 07:30:24 EDT
Right now, Marko Myllynen is preparing man-page for iconv

http://www.spinics.net/lists/linux-man/msg06108.html
Comment 7 Jan Chaloupka 2014-07-22 07:35:26 EDT
New man page containing -s and -c switches for iconv has been created:

http://git.kernel.org/cgit/docs/man-pages/man-pages.git/tree/man1/iconv.1

compared with iconv --help
Comment 13 errata-xmlrpc 2014-10-14 03:26:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html

Note You need to log in before you can comment on or make changes to this bug.