Bug 1011900 - Locales for Catalan are incorrect
Locales for Catalan are incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Florian Weimer
Arjun Shankar
: Patch
Depends On:
Blocks: 1023566 1056252 1172231 1271375
  Show dependency treegraph
 
Reported: 2013-09-25 07:10 EDT by Vicens
Modified: 2016-05-10 17:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: glibc-2.12-1.180.el6
Doc Type: Bug Fix
Doc Text:
The start of the week for the Catalan locale was correct to Monday (from Sunday).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 17:25:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add first_* to ca_ES (581 bytes, patch)
2013-09-25 11:27 EDT, Carlos O'Donell
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 6770 None None None Never

  None (edit)
Description Vicens 2013-09-25 07:10:55 EDT
Description of problem:

First day of the week for catalan language must be Monday(Dilluns).

Version-Release number of selected component (if applicable): 6.4

glibc-common-2.12-1.107.el6_4.4.x86_64 is affected, don't know about other versions

How reproducible:

First day of the week starts on Sunday(diumenge,dg):

bash#  LC_ALL=ca_ES cal 
 
 2013 de setembre  
dg dl dt dc dj dv ds
 1  2  3  4  5  6  7
 8  9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30

/usr/share/i18n/locales/ca_* | grep first

On the local definition should be declared:

first_weekday 2
first_workday 2

Steps to Reproduce:
1.LC_ALL=ca_ES cal 

Actual results:

  2013 de setembre  
dg dl dt dc dj dv ds
 1  2  3  4  5  6  7
 8  9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30


Expected results:
 2013 de setembre  
dl dt dc dj dv ds dg
                   1
 2  3  4  5  6  7  8
 9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30


Monday as first day of the week
Comment 1 kuduka 2013-09-25 07:31:07 EDT
Hello,

Editing the locale and compile it should resolve the problem:

[LOC-y9b7h0@oc6323173122 ~]$diff /usr/share/i18n/locales/ca_ES ca_ES.orig  
104,105d103
< first_weekday   2
< first_workday   2

[LOC-y9b7h0@oc6323173122 locales]$sudo localedef -i ca_ES -f ISO-8859-1 ca_ES

[LOC-y9b7h0@oc6323173122 locales]$LANG=ca_ES cal

  2013 de setembre  
dl dt dc dj dv ds dg
                   1
 2  3  4  5  6  7  8
 9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30
Comment 3 Carlos O'Donell 2013-09-25 11:26:36 EDT
This is already fixed upstream by the fix for sourceware bz 6770.

I'm moving this to rhel-6.6 since it's too late for rhel-6.5.

We will look at this when we scope issues for rhel-6.6.
Comment 4 Carlos O'Donell 2013-09-25 11:27:21 EDT
Created attachment 802921 [details]
Add first_* to ca_ES
Comment 13 errata-xmlrpc 2016-05-10 17:25:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0834.html

Note You need to log in before you can comment on or make changes to this bug.