Bug 1011911 - Defining <outbound-connections> in <management> prevents the server to start
Defining <outbound-connections> in <management> prevents the server to start
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: EAP 6.2.0
Assigned To: Darran Lofthouse
Ladislav Thon
Russell Dickenson
: Regression, TestBlocker
Depends On:
Blocks: eap62-beta-blockers
  Show dependency treegraph
 
Reported: 2013-09-25 07:36 EDT by Ladislav Thon
Modified: 2013-12-15 11:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2155 Blocker Resolved Defining <outbound-connections> in <management> prevents the server to start 2013-10-09 09:05:03 EDT

  None (edit)
Description Ladislav Thon 2013-09-25 07:36:51 EDT
Description of problem:

If I define <outbound-connections> in <management>, which I need e.g. in case I want to authenticate against LDAP for management purposes, the server doesn't start. Instead, it shows this error:

13:30:36,224 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
	at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.server.ServerService.boot(ServerService.java:321) [jboss-as-server-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:250) [jboss-as-controller-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
Caused by: java.lang.UnsupportedOperationException
	at org.jboss.as.server.parsing.StandaloneXml$ManagementXmlDelegate.parseOutboundConnections(StandaloneXml.java:1209) [jboss-as-server-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.domain.management.parsing.ManagementXml.parseManagement_1_5(ManagementXml.java:355) [jboss-as-domain-management-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.domain.management.parsing.ManagementXml.parseManagement(ManagementXml.java:282) [jboss-as-domain-management-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:453) [jboss-as-server-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [jboss-as-server-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [jboss-as-server-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
	at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
	at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.3.0.Final-redhat-6.jar:7.3.0.Final-redhat-6]
	... 3 more

13:30:36,228 FATAL [org.jboss.as.server] (Controller Boot Thread) JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.

Version-Release number of selected component (if applicable):

EAP 6.2.0.ER3

How reproducible:

Always

Steps to Reproduce:
1. Add the following code into the <management> section of standalone.xml:

<outbound-connections>
    <ldap name="ldap" url="ldap://localhost:10389"/>
</outbound-connections>

2. Run ./bin/standalone.sh

Actual results:

The server starts with no error message.

Expected results:

The server doesn't start and it shows an error message.

Additional info:

This works with EAP 6.1.1, so it's a regression.
Comment 1 Ladislav Thon 2013-09-25 07:37:42 EDT
Doh, sorry, I swapped "actual" and "expected" results :-(
Comment 2 JBoss JIRA Server 2013-09-25 07:53:27 EDT
Darran Lofthouse <darran.lofthouse@jboss.com> updated the status of jira WFLY-2155 to Coding In Progress
Comment 4 Ladislav Thon 2013-10-04 10:04:34 EDT
Verified with EAP 6.2.0.ER4.

Note You need to log in before you can comment on or make changes to this bug.