Bug 1011952 - cachemgr.cgi doesn't work by default
Summary: cachemgr.cgi doesn't work by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: squid
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Ondřej Pták
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-25 12:41 UTC by Karel Srot
Modified: 2014-10-14 06:24 UTC (History)
3 users (show)

Fixed In Version: squid-3.1.10-22.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 06:24:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1446 normal SHIPPED_LIVE squid bug fix update 2014-10-14 01:05:47 UTC

Description Karel Srot 2013-09-25 12:41:14 UTC
Description of problem:

When using the default /etc/httpd/conf.d/squid.conf config file shipped with squid the access to a http://localhost/Squid/cgi-bin/cachemgr.cgi is forbidden.

To make it work I had to replace "allow from localhost.localdomain" with "allow from localhost".

Version-Release number of selected component (if applicable):
squid-3.1.10-16.el6

How reproducible:
always

Steps to Reproduce:
1. install httpd
2. install squid
3. start httpd and squid
4. curl http://localhost/Squid/cgi-bin/cachemgr.cgi

Actual results:
access forbidden

Expected results:
cachemgr.cgi is accessible

Additional info:

Comment 3 Ondřej Pták 2014-05-20 16:52:23 UTC
results from /CoreOS/squid/Regression/bz1009402-squid-cachemgr-regression-introduced-in

squid-3.1.10-20.el6_5.x86_64
----------------------------
:: [   FAIL   ] :: File 'query.out' should not contain 'Forbidden' 
:: [   FAIL   ] :: File 'query.out' should contain 'Generated .* by cachemgr.cgi' 

squid-3.1.10-22.el6.x86_64
--------------------------
:: [   PASS   ] :: File 'query.out' should not contain 'Forbidden' 
:: [   PASS   ] :: File 'query.out' should contain 'Generated .* by cachemgr.cgi'

Comment 4 errata-xmlrpc 2014-10-14 06:24:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1446.html


Note You need to log in before you can comment on or make changes to this bug.