Bug 1011992 - High Touch Beta channel mappings should be excluded from channel-cert-mapping.txt
High Touch Beta channel mappings should be excluded from channel-cert-mapping...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
John Sefler
: Regression
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-25 09:51 EDT by John Sefler
Modified: 2013-11-21 16:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:30:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-09-25 09:51:22 EDT
Description of problem:
Quoting dgregor from an old IRC chat based on business logic:
<degregor 5/4/2012> We intentionally exclude HTB channels from the migration script.  It's not a supported use case.

Believing that this statement is still true, the new tooling used to generate the subscription-manager-migration-data package using the product-certs.json file as input needs to explicitly skip over the high touch beta channels.   I believe high touch beta channels are identified as matching regular expression "-htb(-|$)". 

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.3.2-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# grep -- -htb /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-htb: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-6-htb-debuginfo: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-ha-6-htb: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-ha-6-htb-debuginfo: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-lb-6-htb: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-lb-6-htb-debuginfo: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-rs-6-htb: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-rs-6-htb-debuginfo: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-sfs-6-htb: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-server-sfs-6-htb-debuginfo: Server-Server-x86_64-820630ab8815-135.pem
rhel-x86_64-workstation-6-htb: Workstation-Workstation-x86_64-82a3dd9c9805-155.pem
rhel-x86_64-workstation-6-htb-debuginfo: Workstation-Workstation-x86_64-82a3dd9c9805-155.pem
rhel-x86_64-workstation-sfs-6-htb: Workstation-Workstation-x86_64-82a3dd9c9805-155.pem
rhel-x86_64-workstation-sfs-6-htb-debuginfo: Workstation-Workstation-x86_64-82a3dd9c9805-155.pem
[root@jsefler-6 ~]#


Actual results:
above

Expected results:
the grep should not have found any -htb channels

Additional info:
Comment 2 Alex Wood 2013-09-25 12:43:14 EDT
commit 68a4692661e116ac9d6ff17917dab9d4b33ba6ed
Author: Alex Wood <awood@redhat.com>
Date:   Wed Sep 25 12:07:52 2013 -0400

    1011992: Skip high touch beta channels.
Comment 5 John Sefler 2013-09-27 11:58:21 EDT
Verifying Version....
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.4-1.el6.noarch

[root@jsefler-6 ~]# grep -- -htb /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-6 ~]# 

VERIFIED: There are no longer any High Touch Beta "-htb" channel mappings in /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt.
Comment 6 errata-xmlrpc 2013-11-21 16:30:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.