This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1011994 - RBAC: Thread leak in domain mode processes due to address validation
RBAC: Thread leak in domain mode processes due to address validation
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: EAP 6.2.0
Assigned To: Brian Stansberry
Ladislav Thon
Russell Dickenson
:
Depends On:
Blocks: eap62-beta-blockers 1010672
  Show dependency treegraph
 
Reported: 2013-09-25 09:57 EDT by Brian Stansberry
Modified: 2013-12-15 11:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:13:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2139 Major Resolved ProxyStepHandler/Controller need to check access before attempting to read information 2013-11-20 11:53:55 EST

  None (edit)
Description Brian Stansberry 2013-09-25 09:57:55 EDT
Description of problem:

The fix for https://bugzilla.redhat.com/show_bug.cgi?id=1010672 introduce a per-management request leak in slave HostController processes when common requests (e.g. read-resource) are proxied to the slave from the master. I believe the same leak will occur on domain servers for requests proxied from the HostController.

Over time this will result in OOME situations due either to the memory resources used by the threads, or because user process count limites are reached. (For example, on Linux each thread counts as a process.)

Version-Release number of selected component (if applicable):

6.2.0.ER3

How reproducible:

Against the master host controller, execute a series of /host=<nameofslave>:read-resource operations. Monitor the thread count (e.g. using jconsole) on the slave HC process and watch it go up.


We have a fix for this already in the process of getting merged into WildFly master.
Comment 2 Rostislav Svoboda 2013-09-26 06:49:49 EDT
Hi, we think it's Beta Blocker too. We hit this problem with WebConsole experiments on ER3 build.
Comment 4 Jakub Cechacek 2013-10-04 07:00:48 EDT
Verified for 6.2.0.ER4

Tests previously failing due to this issue passed. After looking at threads through visual vm I consider this fixed.

Note You need to log in before you can comment on or make changes to this bug.