Bug 1012019 - OOTB - The BPEL console does not allow users to login until after a BPEL process is deployed
OOTB - The BPEL console does not allow users to login until after a BPEL proc...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: BPEL Integration (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Gary Brown
lvaskova
:
: 947313 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 10:49 EDT by Len DiMaggio
Modified: 2014-02-06 10:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
For Beta User has to deploy before attempting to log in to the conosle, or login will not work.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BPEL login screenshot (7.50 KB, image/png)
2013-09-25 10:51 EDT, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RIFTSAW-545 Major Resolved Start engine if not available when console starts 2016-11-14 05:34 EST

  None (edit)
Description Len DiMaggio 2013-09-25 10:49:59 EDT
Description of problem:

Related to bugzilla:  https://bugzilla.redhat.com/show_bug.cgi?id=1011665

After BPEL users are created, they cannot log into the BPEL console until after a BPEL process is deployed. Before a process is deployed, login attempts are blocked - the user is shown this error:

     BPEL Engine is not started

Version-Release number of selected component (if applicable):
ER3

How reproducible:
100%

Steps to Reproduce:
1. Create users as described in: https://bugzilla.redhat.com/show_bug.cgi?id=1011665
2. Attempt to log into the BPEL console
3. 

Actual results:
The user is blocked from logging into the console

Expected results:
Why can't the user login before a BPEL process is deployed?

Additional info:
See attached screenshot
Comment 1 Len DiMaggio 2013-09-25 10:51:22 EDT
Created attachment 802899 [details]
BPEL login screenshot
Comment 2 Gary Brown 2013-09-25 11:06:58 EDT
The reason for this is that the BPEL console (currently) needs the BPEL engine to be initialized. However the BPEL engine is only initialized after a BPEL process is deployed - to avoid unnecessary startup delay in switchyard if user is not using BPEL.
Comment 3 Gary Brown 2013-09-25 12:12:58 EDT
Had a look, and this error is displayed if the console gets a login failure that is not authentication related:

bpm-console project:
gui/war/src/main/java/org/jboss/bpm/console/client/LoginView.java

This won't be a quick fix, so suggest it should be post-beta.
Comment 4 Anne-Louise Tangring 2013-09-26 08:45:23 EDT
We need to make sure it's documented for Beta so the user knows to deploy before attempting to log in to console. Agree it has to be fixed for GA.
Comment 8 Gary Brown 2013-10-31 08:30:50 EDT
Applied part of the fix - to enable the console server to cause the engine to be initialized even if no BPEL processes have been deployed. Remainder of solution should be provided when the login mechanism is changed in the console to use the Overlord SSO mechanism.
Comment 9 JBoss JIRA Server 2013-10-31 08:34:34 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RIFTSAW-545 to Resolved
Comment 10 Gary Brown 2013-10-31 11:57:33 EDT
*** Bug 947313 has been marked as a duplicate of this bug. ***
Comment 11 lvaskova 2013-12-16 04:46:10 EST
Verified on ER7

Note You need to log in before you can comment on or make changes to this bug.