Bug 1012025 - Beaglebone Black missing USB and Network
Beaglebone Black missing USB and Network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-09-25 10:59 EDT by Paul Whalen
Modified: 2014-02-03 03:08 EST (History)
11 users (show)

See Also:
Fixed In Version: kernel-3.12.7-300.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 03:08:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console outut showing boot, update, update kernel, failed-boot. (47.11 KB, application/x-gzip)
2013-12-15 06:51 EST, zachw
no flags Details

  None (edit)
Description Paul Whalen 2013-09-25 10:59:23 EDT
Description of problem:
Minimal support for the Beaglebone Black was added in kernel-3.11.0-300.fc20, the BBB will now boot, but lacks working network and usb drivers. 

Version-Release number of selected component (if applicable):

kernel-3.11.0-300.fc20+
Comment 1 Peter Robinson 2013-09-28 08:50:22 EDT
I'll be looking at the BBBlack pretty closely when I'm back in the UK in a week.
Comment 2 Peter Robinson 2013-10-17 09:41:43 EDT
With kernel-3.11.4-302.fc20 and Fedora 20 beta TC4 and later the network interface works:

Brief overview of what now works:
* serial console - working
* Micro SD - working
* eMMC - working
* network - working
* HDMI - should work (untested)
* usb - not working
* i2c/spi/gpio - basic testing shows it works, there's still more to be enabled and tested
Comment 3 Adam Williamson 2013-12-12 20:33:27 EST
Can someone please provide detailed status of the BBB with Final for commonbugs purposes? (If I don't get around to it myself...)
Comment 4 Peter Robinson 2013-12-13 03:50:01 EST
Final status for GA is:

Brief overview of what now works:
* serial console - working
* Micro SD - working
* eMMC - working
* network - working
* HDMI - not working
* usb - not working
* i2c/spi/gpio - basic testing shows it works, there's still more to be enabled and tested

3.12.5 from nodebug [1] is now working with mmc/usb/hdmi/network. I've updated the Common Bugs page with details.


[1] http://alt.fedoraproject.org/pub/alt/rawhide-kernel-nodebug/armhfp/
Comment 5 zachw 2013-12-15 06:51:58 EST
Created attachment 836912 [details]
serial console outut showing boot, update, update kernel, failed-boot.
Comment 6 zachw 2013-12-15 06:57:16 EST
I got an error during boot on the rawhide-nodebug kernel, the attached serial output shows two attempted boots (at the end). Strange story: I did this yesterday, blew away the install with rawhide nightly image, got some other error (didn't save that one), went back and did f20 update again and it worked fine for a while. No errors. Turned the machine off, came back a while later and the same error is back.

[   32.778093] Unhandled fault: external abort on non-linefetch (0x1008) at 0xe09f0c20
[   32.786175] Internal error: : 1008 [#1] SMP ARM
[   32.790941] Modules linked in: snd_pcm_dmaengine ac97_bus snd_seq snd_seq_device snd_pcm vfat fat snd_page_alloc snd_timer snd omapdss(+) soundcore ti_cpsw tda998x davinci_cpdma ptp pps_core tilcdc backlight tps65217_regulator at24 omap_wdt musb_am335x nfsd drm_kms_helper drm mmc_block
[   32.817726] CPU: 0 PID: 69 Comm: kworker/0:2 Not tainted 3.12.5-1.fc21.armv7hl #1
[   32.825640] Workqueue: events cpts_overflow_check [ti_cpsw]
[   32.831506] task: db1d2140 ti: db212000 task.ti: db212000
[   32.837195] PC is at cpts_fifo_read.constprop.7+0x28/0xfc [ti_cpsw]
[   32.843797] LR is at cpts_systim_read+0x20/0x94 [ti_cpsw]
[   32.849476] pc : [<bf168f10>]    lr : [<bf1691dc>]    psr: 600f0093
[   32.849476] sp : db213e98  ip : 00000000  fp : 00000000
[   32.861544] r10: c09b80c0  r9 : db45c8fc  r8 : 00000001
[   32.867033] r7 : 00000010  r6 : ffffffff  r5 : db45c818  r4 : db45c824
[   32.873896] r3 : e09f0c00  r2 : 00000001  r1 : 00000001  r0 : db45c818
[   32.880760] Flags: nZCv  IRQs off  FIQs on  Mode SVC_32  ISA ARM  Segment kernel
[   32.888532] Control: 10c5387d  Table: 9bd74019  DAC: 00000015
[   32.894574] Process kworker/0:2 (pid: 69, stack limit = 0xdb212248)
[   32.901162] Stack: (0xdb213e98 to 0xdb214000)
Comment 7 John Dulaney 2013-12-15 10:04:04 EST
Looks like it blew up trying to bring up ethernet.
Comment 8 John Dulaney 2013-12-15 10:30:10 EST
Move all discussions of the ethernet bug to https://bugzilla.redhat.com/show_bug.cgi?id=1043271

Thanks.

Note You need to log in before you can comment on or make changes to this bug.