Bug 1012076 - impossible war deployment to EAP6 in Windows
impossible war deployment to EAP6 in Windows
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.2
x86_64 Windows
unspecified Severity urgent
: ER03
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks: 902347 jon32-Beta-Blockers-1006862
  Show dependency treegraph
 
Reported: 2013-09-25 12:23 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 05:57:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-09-25 12:23:45 EDT
Description of problem:
impossible war deployment to EAP6 in Windows 

Version-Release number of selected component (if applicable):
JON 3.2 ER1

How reproducible:
2 out of 2

Steps to Reproduce:
1. install and start jon server-agent-storage in windows 2008
2. install and start eap6.1 in windows2008 (downloaded from http://download.devel.redhat.com/released/JBEAP-6/6.1.1/)
3. create child deployment for EAP6 

Actual results:
http://d.pr/v/4ItN

Expected results:
war deployed


Additional info:
same exception with EAP 6.1.1 embeded with jon
 same scneario in linux >  http://d.pr/i/2b6y
Comment 1 Thomas Segismont 2013-09-30 10:42:57 EDT
Can you please attach the error message shown in red in your video? Thanks

I've tried to reproduce on EAP 6.1.0 without success. This must be an EAP6.1.1 specific issue.
Comment 2 Thomas Segismont 2013-09-30 11:00:54 EDT
Just tried with EAP 6.1.1 as managed server. Could not reproduce either. This may not be an RHQ issue but a pure JON issue.
Comment 3 Jay Shaughnessy 2013-09-30 11:09:27 EDT
Quick test with RHQ worked for me on Win7.  Will try with ER2.
Comment 4 Armine Hovsepyan 2013-09-30 11:36:21 EDT
exception fragemtn from gui -> http://pastebin.test.redhat.com/167099
Comment 5 Thomas Segismont 2013-09-30 15:42:46 EDT
Which user is running RHQ services?

Can you look at the server log and tell me what is the value of the "java.io.tmpdir" property?

Thanks
Comment 6 Thomas Segismont 2013-10-01 05:22:33 EDT
The service was installed and started with Local System Account.

This account has the following temporary directory:
C:\Windows\system32\config\systemprofile\AppData\Local\Temp\

But it was not present on the filesystem.

After creating the directory, the Child Deployment Resource could be added.
Comment 7 Armine Hovsepyan 2013-10-01 05:57:28 EDT
Thanks Thomas. Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.