Bug 1012082 - Unable to login using smart card after adding the coolkey module manually with full path /usr/lib64/pkcs11/libcoolkeypk11.so
Unable to login using smart card after adding the coolkey module manually wit...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pam_pkcs11 (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 12:32 EDT by Roshni
Modified: 2014-10-14 02:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: pam_pkcs11-0.6.2-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:43:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roshni 2013-09-25 12:32:47 EDT
Description of problem:
Unable to login using smart card after adding the coolkey module manually with full path /usr/lib64/pkcs11/libcoolkeypk11.so



Version-Release number of selected component (if applicable):
pam_pkcs11-0.6.2-13.el6

How reproducible:
always

Steps to Reproduce:
1. rpm -ivh coolkey-1.1.0-30.el6.x86_64
2. Logout and login with smartcard - worked
3. modutil -delete "CoolKey PKCS #11 Module" -dbdir /etc/pki/nssdb
4. modutil -add "CoolKey PKCS #11 Module" -dbdir /etc/pki/nssdb -libfile
/usr/lib64/pkcs11/libcookeypk11.so
5. Logout, smart card login not enabled
6. modutil -delete "CoolKey PKCS #11 Module" -dbdir /etc/pki/nssdb
7. cd /etc/pki/nssdb
8. chmod +r pkcs11.txt
9. modutil -add "CoolKey PKCS #11 Module" -dbdir /etc/pki/nssdb -libfile
libcookeypk11.so
10. Logout, smart card login - enabled and logged in successfully

Actual results:
Unable to login using smart card after adding the coolkey module with the full path to pkcs11 file

Expected results:
Should be able to login with smart card

Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 21:56:12 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Roshni 2014-07-14 11:30:38 EDT
Verified on pam_pkcs11-0.6.2-14.el6.x86_64
Comment 6 Roshni 2014-07-18 10:22:05 EDT
Verification steps on RHEL 6.6:

1. rpm -ivh pam_pkcs11-0.6.2-14.el6.x86_64 and other smart card related packages (yum groupinstall "Smart card support")
2. Logout and login with smartcard - worked
3. modutil -delete "CoolKey PKCS #11 Module" -dbdir /etc/pki/nssdb
4. modutil -add "CoolKey PKCS #11 Module" -dbdir /etc/pki/nssdb -libfile
/usr/lib64/pkcs11/libcookeypk11.so
5. Logout, smart card login works
Comment 7 errata-xmlrpc 2014-10-14 02:43:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1474.html

Note You need to log in before you can comment on or make changes to this bug.