Bug 1012110 - libguestfs fails to parse /var/lib/rpm/Name during inspection
libguestfs fails to parse /var/lib/rpm/Name during inspection
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 13:53 EDT by Anitha Udgiri
Modified: 2013-10-19 17:52 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 11:41:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log (2.27 MB, application/x-compressed-tar)
2013-09-25 13:53 EDT, Anitha Udgiri
no flags Details

  None (edit)
Description Anitha Udgiri 2013-09-25 13:53:25 EDT
Created attachment 802985 [details]
Debug log

Description of problem:
While trying to convert a RHEL 6.4 server using virt-p2v , the following error is noticed:

virt-v2v: Died at /usr/bin/virt-p2v-server line 404, <> line 7.

Uploading the debug log of this process.
Comment 1 Richard W.M. Jones 2013-09-25 13:59:35 EDT
The error seems to be:

libguestfs: read_db_dump command: db_dump -k '/tmp/libguestfsLahEFY/3-rpm_Name'
libguestfs: trace: inspect_list_applications = NULL (error)

(from parsing /var/lib/rpm/Name from the disk image).  Actually
there are two problems here, firstly that this fails and secondly
that there is no error message set by libguestfs.

Setting to NEEDINFO because Anitha has promised to
get the /var/lib/rpm/Name file from the origin.
Comment 2 Anitha Udgiri 2013-09-26 14:22:52 EDT
(In reply to Richard W.M. Jones from comment #1)
 
> Setting to NEEDINFO because Anitha has promised to
> get the /var/lib/rpm/Name file from the origin.

I haven't heard back from the Customer yet on this request. Will upload the data as soon as they send it across.
Comment 4 Richard W.M. Jones 2013-10-02 08:41:43 EDT
I'm baffled by what could cause this bug.  I suspect the actual
libguestfs error is being hidden somewhere.

What versions of the following packages does the customer
have installed on the v2v conversion server?

- db4-utils
- libguestfs
- virt-v2v
- qemu
- kernel

(Do we have a sosreport?)
Comment 5 Richard W.M. Jones 2013-10-02 08:55:51 EDT
It would also be cool if they could run the following
commands on the conversion server.  Note that 'Name' is
the Name file that they supplied to us (also attached to
this bug):

db_dump -k Name > /tmp/output
echo $?

and note down the exit code ($?) and send us the output file.
Comment 11 RHEL Product and Program Management 2013-10-13 21:56:03 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 13 Richard W.M. Jones 2013-10-19 17:52:04 EDT
Upstream commit d6e5a6546afeb1554e676e5a4197002559f6cde7
uses AC_PATH_PROG(S) so that the paths to db_dump etc are
encoded in the binary.  This should mean this kind of bug
cannot happen (in libguestfs >= 1.25).

Note You need to log in before you can comment on or make changes to this bug.