Bug 1012197 - Reports of task results should be displayed with alternating backgrounds
Reports of task results should be displayed with alternating backgrounds
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15
: ---
Assigned To: Dan Callaghan
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 21:57 EDT by Nick Coghlan
Modified: 2013-10-02 22:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 22:27:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot-task-0.15 (147.48 KB, image/png)
2013-09-30 02:22 EDT, wangjing
no flags Details
screenshot-task-0.14.1 (151.23 KB, image/png)
2013-09-30 02:23 EDT, wangjing
no flags Details

  None (edit)
Description Nick Coghlan 2013-09-25 21:57:56 EDT
In previous versions, alternating tasks (including the header and all results) were displayed with alternating white/gray backgrounds.

The new theme in 0.15 currently displays them all with white backgrounds, making it difficult to see which results belong to which tasks.
Comment 1 Dan Callaghan 2013-09-26 00:38:47 EDT
On Gerrit: http://gerrit.beaker-project.org/2299
Comment 3 wangjing 2013-09-27 05:29:37 EDT
tested on beaker-devel Version 0.15.0rc2(20130927)-->fail

Steps:
1. on job page(Scheduler->Jobs, click one job id), click 'Show  Results', check the backgroud of tasks.
2. on recipe page(Scheduler->Recipes, click one recipe id), click 'Show  Results', check the backgroud of tasks.

Actual results:
no alternating white/gray backgrounds displayed.

Expected results:
alternating white/gray backgrounds displayed for different recipe task.
Comment 4 Nick Coghlan 2013-09-27 06:50:25 EDT
Huh, I checked this one and it showed the alternating background for me. Could you add a link in a private comment to the job result that failed the check?
Comment 5 wangjing 2013-09-30 02:22:44 EDT
Created attachment 804908 [details]
screenshot-task-0.15
Comment 6 wangjing 2013-09-30 02:23:56 EDT
Created attachment 804909 [details]
screenshot-task-0.14.1
Comment 8 Nick Coghlan 2013-09-30 02:35:39 EDT
Oh, now I see the problem - the hover highlight and the alternate highlight in the default Bootstrap them are almost exactly the same shade of grey (the hover highlight is just a tiny bit darker than the alternate highlight).

That's a separate issue - this bug is about the fact that previously the alternative highlights weren't there *at all* in 0.15.
Comment 9 Nick Coghlan 2013-09-30 02:57:43 EDT
Moving to VERIFIED, since the hover vs alternate row highlight issue is unrelated to this.
Comment 10 Nick Coghlan 2013-10-02 22:27:35 EDT
Beaker 0.15 has been released.

Note You need to log in before you can comment on or make changes to this bug.