Bug 1012216 - quota: zero byte file created
quota: zero byte file created
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Raghavendra G
:
Depends On: 998893
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 23:19 EDT by Raghavendra G
Modified: 2014-04-17 07:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 998893
Environment:
Last Closed: 2014-04-17 07:48:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-26 02:27:23 EDT
REVIEW: http://review.gluster.org/6004 (storage/posix: tweak ia_blocks only if ia_size is non-zero) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Anand Avati 2013-10-04 04:18:05 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 3 Anand Avati 2013-10-09 05:30:49 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 4 Anand Avati 2013-10-10 12:08:06 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 5 Anand Avati 2013-10-11 05:47:09 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 6 Anand Avati 2013-10-11 08:17:22 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 7 Anand Avati 2013-10-11 21:43:01 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 8 Anand Avati 2013-10-16 02:05:17 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 9 Anand Avati 2013-10-24 08:30:06 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 10 Anand Avati 2013-10-28 01:56:32 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#9) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 11 Anand Avati 2013-10-28 06:21:16 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#10) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 12 Anand Avati 2013-10-28 09:49:25 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#11) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 13 Anand Avati 2013-10-28 12:38:01 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#12) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 14 Anand Avati 2013-10-31 02:02:35 EDT
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#13) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 15 Anand Avati 2013-11-04 06:12:50 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write  cannot fit into available space.) posted (#14) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 16 Anand Avati 2013-11-11 08:57:51 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#15) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 17 Anand Avati 2013-11-11 11:31:58 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#16) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 18 Anand Avati 2013-11-11 13:07:13 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#17) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 19 Anand Avati 2013-11-12 10:12:25 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#18) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 20 Anand Avati 2013-11-13 06:17:03 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#19) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 21 Anand Avati 2013-11-14 07:03:31 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#20) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 22 Anand Avati 2013-11-14 07:44:14 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#21) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 23 Anand Avati 2013-11-26 01:05:25 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#38) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 24 Anand Avati 2013-11-26 05:45:11 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#39) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 25 Anand Avati 2013-11-26 06:40:24 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#40) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 26 Anand Avati 2013-11-26 07:28:24 EST
REVIEW: http://review.gluster.org/6035 (features/quota: make writes short when the entire write cannot fit into available space.) posted (#41) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 27 Anand Avati 2013-11-26 13:26:36 EST
COMMIT: http://review.gluster.org/6035 committed in master by Anand Avati (avati@redhat.com) 
------
commit 3f1ebe0298450cb8770a8753fe3a8a2519f78911
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Fri Oct 4 13:37:38 2013 +0530

    features/quota: make writes short when the entire write cannot fit into available space.
    
    This patch aims to prevent creation of infinite zero byte sized files
    due to amount of storage available before exceeding quota limit
    being less than write sizes. Imagine x bytes of storage is available
    before we exceed quota limit and quota enforcer is receiving writes of
    size y and (y > x). In this scenario, if we run a shell script like:
    
       # for i in $(seq 1 10); do dd if=/dev/zero of=$i bs=y count=1; done
    
    Then, we would end up with 10 zero byte sized files, because we allow
    only complete writes and all writes will fail because of lack of space.
    However, creates succeed since a create itself will consume zero
    bytes. In this pattern of creates and writes, size of volume would
    never grow and x bytes of space will always be available and we can
    end up with an infinite number of zero byte sized files.
    
    Change-Id: Ice148d6a2207883e41759f7b0be73abaa3198b41
    BUG: 1012216
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/6035
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 28 Niels de Vos 2014-04-17 07:48:43 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.