Bug 101224 - Unreadable russian (cyrillic) letters in gtk+ apps with UTF-8 locale.
Summary: Unreadable russian (cyrillic) letters in gtk+ apps with UTF-8 locale.
Status: CLOSED DUPLICATE of bug 68725
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 09:19 UTC by Roman J. Mashirov
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/gtk/gtkrc.ru_RU.utf8 which fixes the problem (134 bytes, patch)
2003-07-30 09:21 UTC, Roman J. Mashirov
no flags Details | Diff

Description Roman J. Mashirov 2003-07-30 09:19:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.4) Gecko/20030701

Description of problem:
gtk 1 programs (gimp, gnumeric, etc.) represent squares instead of russian
letters while using UTF-8 locale due to incorrect configuration in /etc/gtk



Version-Release number of selected component (if applicable):
gtk+-1.2.10-25

How reproducible:
Always

Steps to Reproduce:
1. Insatll with Russian locale
2. run any gtk+ app (gimp)
    

Additional info:

To fix the problem need to add aproppriate gtk configuration with correct
cyrillic font (/etc/gtk/gtkrc.ru_RU.utf8) Appropriate configuration file attached.

Though, in RH 9 only one font from the default distribution has correct cyrillic
in UNICODE, is it possible to add more fonts?

Comment 1 Roman J. Mashirov 2003-07-30 09:21:20 UTC
Created attachment 93256 [details]
/etc/gtk/gtkrc.ru_RU.utf8 which fixes the problem

Comment 2 Owen Taylor 2003-10-27 20:25:06 UTC
The normal UTF-8 file would work perfectly fine for russian if 
Xlib was configured correctly.

*** This bug has been marked as a duplicate of 68725 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:57:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.