Bug 1012280 - [abrt] list_add corruption. prev->next should be next (ffff88020a591c08), but was ffff8801fed77b70. (prev=ffff8801fed77b70).
[abrt] list_add corruption. prev->next should be next (ffff88020a591c08), but...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:d58e7bef83eb98e3a9e87886db8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 03:57 EDT by john.haxby@oracle.com
Modified: 2014-01-06 11:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 11:26:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (88.67 KB, text/plain)
2013-09-26 03:57 EDT, john.haxby@oracle.com
no flags Details

  None (edit)
Description john.haxby@oracle.com 2013-09-26 03:57:09 EDT
Description of problem:
I think this may have been caused by trying to establish a link to a bluetooth mouse after a resuming from STR.

Additional info:
reporter:       libreport-2.1.7
list_add corruption. prev->next should be next (ffff88020a591c08), but was ffff8801fed77b70. (prev=ffff8801fed77b70).
Modules linked in: usb_storage hidp xt_REDIRECT nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_idt dell_wmi ppdev sparse_keymap arc4 dell_laptop dcdbas coretemp iwldvm btusb bluetooth kvm_intel mac80211 snd_hda_intel kvm snd_hda_codec snd_hwdep snd_seq snd_seq_device microcode iwlwifi snd_pcm i2c_i801 serio_raw cfg80211 intel_ips sdhci_pci snd_page_alloc rfkill sdhci snd_timer lpc_ich snd mmc_core soundcore mfd_core e1000e shpchp ptp pps_core wmi parport_pc parport acpi_cpufreq mperf uinput btrfs libcrc32c xor zlib_deflate raid6_pq dm_crypt crc32_pclmul crc32c_intel i915 ghash_clmulni_intel i2c_algo_bit drm_kms_helper firewire_ohci firewire_core drm crc_itu_t i2c_core video
CPU: 1 PID: 681 Comm: kworker/u17:1 Not tainted 3.11.1-200.fc19.x86_64 #1
Hardware name: Dell Inc. Latitude E6410/0667CC, BIOS A07 02/15/2011
Workqueue: hci0 hci_rx_work [bluetooth]
 0000000000000009 ffff88020b0a3b88 ffffffff816476af ffff88020b0a3bd0
 ffff88020b0a3bc0 ffffffff810670dd ffff8801fed77b70 ffff88020a591c08
 ffff8801fed77b70 ffff88020d8d59b8 0000000000000000 ffff88020b0a3c20
Call Trace:
 [<ffffffff816476af>] dump_stack+0x45/0x56
 [<ffffffff810670dd>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106714c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff8131063c>] __list_add+0xac/0xc0
 [<ffffffff8163d202>] klist_add_tail+0x32/0x40
 [<ffffffff813eee9a>] device_add+0x4da/0x7a0
 [<ffffffffa053f57e>] hci_conn_add_sysfs+0x4e/0xd0 [bluetooth]
 [<ffffffffa05330dc>] hci_event_packet+0x186c/0x2ea0 [bluetooth]
 [<ffffffffa053e55f>] ? hci_send_to_sock+0xff/0x1d0 [bluetooth]
 [<ffffffffa0523cb8>] hci_rx_work+0x1b8/0x3c0 [bluetooth]
 [<ffffffff81081055>] process_one_work+0x175/0x430
 [<ffffffff81081c7b>] worker_thread+0x11b/0x3a0
 [<ffffffff81081b60>] ? rescuer_thread+0x340/0x340
 [<ffffffff810885c0>] kthread+0xc0/0xd0
 [<ffffffff81088500>] ? insert_kthread_work+0x40/0x40
 [<ffffffff816567ac>] ret_from_fork+0x7c/0xb0
 [<ffffffff81088500>] ? insert_kthread_work+0x40/0x40
Comment 1 john.haxby@oracle.com 2013-09-26 03:57:17 EDT
Created attachment 803262 [details]
File: dmesg
Comment 2 Tore Anderson 2013-10-07 09:03:31 EDT
Description of problem:
Made bluetooth discoverable

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.11.2-201.fc19.x86_64 root=UUID=c945f436-9099-474e-bffb-8ea4531c49a8 ro rootflags=subvol=root rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=no rd.luks=0 rhgb quiet LANG=nb_NO.UTF-8
kernel:         3.11.2-201.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
list_add corruption. prev->next should be next (ffff880232339188), but was ffff88021aa30570. (prev=ffff88021aa30570).
Modules linked in: hidp rpcsec_gss_krb5 auth_rpcgss nfsv4 dns_resolver nfs lockd sunrpc fscache nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle iptable_security iptable_raw nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep snd_hda_codec_hdmi snd_hda_codec_idt iTCO_wdt iTCO_vendor_support x86_pkg_temp_thermal coretemp hp_wmi sparse_keymap joydev arc4 kvm crc32_pclmul crc32c_intel iwldvm snd_hda_intel ghash_clmulni_intel snd_hda_codec cdc_mbim mac80211 microcode snd_hwdep uvcvideo snd_seq videobuf2_vmalloc btusb videobuf2_memops snd_seq_device videobuf2_core cdc_ncm serio_raw bluetooth snd_pcm videodev usbnet iwlwifi snd_page_alloc i2c_i801 mii lpc_ich cdc_wdm mfd_core cdc_acm cfg80211 media snd_timer sdhci_pci snd sdhci e1000e rfkill mmc_core ptp soundcore shpchp pps_core wmi tpm_tis tpm_infineon hp_accel lis3lv02d input_polldev mperf uinput binfmt_misc btrfs libcrc32c xor zlib_deflate raid6_pq i915 i2c_algo_bit drm_kms_helper drm i2c_core video ecryptfs encrypted_keys trusted tpm tpm_bios
CPU: 0 PID: 325 Comm: kworker/u17:1 Not tainted 3.11.2-201.fc19.x86_64 #1
Hardware name: Hewlett-Packard HP EliteBook Folio 9470m/18DF, BIOS 68IBD Ver. F.40 02/01/2013
Workqueue: hci0 hci_rx_work [bluetooth]
 0000000000000009 ffff8802317c3b88 ffffffff8164775f ffff8802317c3bd0
 ffff8802317c3bc0 ffffffff8106715d ffff88021aa30570 ffff880232339188
 ffff88021aa30570 ffff88022193f1b8 0000000000000000 ffff8802317c3c20
Call Trace:
 [<ffffffff8164775f>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff810671cc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff8131079c>] __list_add+0xac/0xc0
 [<ffffffff8163d292>] klist_add_tail+0x32/0x40
 [<ffffffff813ef01a>] device_add+0x4da/0x7a0
 [<ffffffffa04c657e>] hci_conn_add_sysfs+0x4e/0xd0 [bluetooth]
 [<ffffffffa04ba0dc>] hci_event_packet+0x186c/0x2ea0 [bluetooth]
 [<ffffffffa04aacb8>] hci_rx_work+0x1b8/0x3c0 [bluetooth]
 [<ffffffff810810d5>] process_one_work+0x175/0x430
 [<ffffffff81081cfb>] worker_thread+0x11b/0x3a0
 [<ffffffff81081be0>] ? rescuer_thread+0x340/0x340
 [<ffffffff81088640>] kthread+0xc0/0xd0
 [<ffffffff81088580>] ? insert_kthread_work+0x40/0x40
 [<ffffffff8165686c>] ret_from_fork+0x7c/0xb0
 [<ffffffff81088580>] ? insert_kthread_work+0x40/0x40
Comment 3 Justin M. Forbes 2014-01-03 17:06:59 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 4 john.haxby@oracle.com 2014-01-06 07:00:43 EST
I don't have this problem in 3.12.6-200.fc19.x86_64.   My bluetooth mouse started reconnecting after an STR a little while ago and I'm not sure if it was a kernel update or something else.   The list corruption problem was always intermittent but I haven't had that for a while either.

Sorry for not updating this bug sooner, I think you can close it now.
Comment 5 Josh Boyer 2014-01-06 11:26:50 EST
Ok thanks.

Note You need to log in before you can comment on or make changes to this bug.