Bug 1012283 - [origin_broker_110] can't add mongodb to an application, got message 'connection failed'
[origin_broker_110] can't add mongodb to an application, got message 'connect...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 03:58 EDT by Jianwei Hou
Modified: 2015-05-14 20:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:31:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broker log (29.43 KB, text/x-log)
2013-09-26 03:58 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2013-09-26 03:58:14 EDT
Created attachment 803263 [details]
broker log

Description of problem:
Unable to mongodb-2.2 to an existing application, rhc client return error message 'connection failed'. 

Version-Release number of selected component (if applicable):
always

How reproducible:
On devenv_3832

Steps to Reproduce:
1. Create an application
2. Add mongodb-2.2 to it

Actual results:
2. rhc cartridge-add mongodb-2.2 -a p1
Adding mongodb-2.2 to application 'p1' ... exception: connect failed


Expected results:
Should be successful from the 1st time.

Additional info:
Comment 1 Rajat Chopra 2013-09-26 18:25:59 EDT
Works on the latest devenv. 
The reported error looks like a connection issue from rhc anyway. The broker was unreachable it seems.
Comment 2 Jianwei Hou 2013-09-26 22:25:49 EDT
Verified on devenv_3836
This problem still happens to me, but after ssh into the instance and doing the same operation, the problem is not reproduced. Possibly this is caused by my slow network, thanks.

Note You need to log in before you can comment on or make changes to this bug.