Bug 1012298 - swift: cli not clear for create container
swift: cli not clear for create container
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
4.0
x86_64 Linux
unspecified Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Pete Zaitcev
Haim
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 04:47 EDT by Dafna Ron
Modified: 2016-04-26 13:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 03:06:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1231321 None None None Never
OpenStack gerrit 51706 None None None Never

  None (edit)
Description Dafna Ron 2013-09-26 04:47:20 EDT
Description of problem:

on horizon there it's very clear but looking at the cli, since there is no create command I was unable to figure it out until I asked people who have been working with swift for a while.

If you look at the help files than post will show this:
post Updates meta information for the account, container,
                         or object

There is no indication that you can create a new empty container using this command, only change existing ones - so unless I asked i would have never guessed to use it.

Version-Release number of selected component (if applicable):

openstack-swift-1.8.0-6.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. run swift --help 
2. 
3.

Actual results:

its unclear how we can create a new container from cli

Expected results:

there should be a create command from containers or the help files should be clearer 

Additional info:
Comment 1 Dafna Ron 2013-09-26 04:47:57 EDT
https://bugs.launchpad.net/swift/+bug/1231321
Comment 2 Pete Zaitcev 2013-10-15 10:18:26 EDT
Fixed upstream. Dafna, would that be ok to close with resolution "upstream"?

Note You need to log in before you can comment on or make changes to this bug.