Bug 1012299 - Cups 1.6.3 not printing on shared printer on cups 1.4.2
Cups 1.6.3 not printing on shared printer on cups 1.4.2
Status: CLOSED DUPLICATE of bug 1010580
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
19
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 04:50 EDT by Jaco
Modified: 2013-09-27 05:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 05:57:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-printer troubleshoot file (15.19 MB, text/plain)
2013-09-26 04:50 EDT, Jaco
no flags Details

  None (edit)
Description Jaco 2013-09-26 04:50:07 EDT
Created attachment 803280 [details]
system-config-printer troubleshoot file

Description of problem:


Version-Release number of selected component (if applicable):
Client: Fedora 19 (Linux version 3.9.9-302.fc19.i686.PAE)
        CUPS 1.6.3-4.fc19
        Printer driver: HL2140.ppd
Server: CentOS 6.4 (Linux version 2.6.32-358.18.1.el6.i686)
        CUPS 1.4.2-50.el6_4.5
        Printer driver: HL2140.ppd

How reproducible:
Every time.

Steps to Reproduce:
1. Select shared printer on server as printer and print document to printer.

Actual results:
No action from printer.
Cups (client and server) indicate print job successfully completed.

Expected results:
Normal printing expected

Additional info:
On Server access_log it appears that job has been received and successfully printed.
On Client access_log it appears that job has been received and successfully printed.
No errors logged in server error_log
system-config-printer troubleshoot log attached.
Comment 1 Jiri Popelka 2013-09-26 08:02:01 EDT
Are you able to print on the shared printer from some other machine ?
Where did you get the ppd/driver you use on the server ?
http://openprinting.org/printer/Brother/Brother-HL-2140
recommends hpijs-pcl5e driver.

It's also possible that the printer queue on client is wrongly configured, see bug #1010580, comment #9. How did you configure it ?
Comment 2 Jaco 2013-09-27 04:57:56 EDT
Jiri

No, I was not able to print from any other machine, but printing from the server was without a problem.
I tried various drivers, including hpijs-pcl5e, with same effect.

However, I managed to fix the problem as follows:
Based on advice in bug #1010580, comment #9, I removed driver from clients by 
lpadmin -p HL2140 -m raw.
This caused the test page from client to be printed as a pdf-banner page.  I changed the driver on the server to foomatic/hl1250.  The test page and any subsequent pages then printed successfully.
I tried the hpijs-pcl5e driver, but the background have a greyish colour while the foomatic/hl1250 is perfect.
Will now try to implement it on all the other machines.

Thanks for your assistance.
I believe this is not a bug and may be closed.
Comment 3 Jiri Popelka 2013-09-27 05:57:00 EDT
(In reply to Jaco from comment #2)
> However, I managed to fix the problem as follows:
> Based on advice in bug #1010580, comment #9, I removed driver from clients
> by lpadmin -p HL2140 -m raw.

Great, closing as duplicate then.

> This caused the test page from client to be printed as a pdf-banner page.

That's bug #919489 - we've had no idea how to solve this.

*** This bug has been marked as a duplicate of bug 1010580 ***

Note You need to log in before you can comment on or make changes to this bug.