This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012327 - /etc/shells still lists /sbin/nologin not /usr/sbin/nologin
/etc/shells still lists /sbin/nologin not /usr/sbin/nologin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 05:45 EDT by Adam Williamson
Modified: 2013-09-26 13:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 06:55:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-09-26 05:45:07 EDT
See summary. Post-/usr-move it should probably be the other way around.
Comment 1 Ondrej Vasik 2013-09-26 06:55:39 EDT
Well, not really true, it already lists both, I added that in setup-2.8.67-1.f20 because of #922527. IMHO it should list both(as it does now), as the common habbit is to use shorter shellnames - and both work fine - I think we will not be able to get rid off #!/bin/bash shebangs anytime soon. As I see the /etc/shells updated, I assume you have /etc/shells.rpmnew in your /etc/ (and this was caused by updated /etc/shells file and distro upgrade mechanism). Closing CURRENTRELEASE, as I think this is already resolved in Fedora 20+.
Comment 2 Adam Williamson 2013-09-26 13:49:37 EDT
ah, indeed, missed the .rpmnew - sorry!

Note You need to log in before you can comment on or make changes to this bug.