Bug 1012346 - Provide state of async tasks of all volumes in a new sub-command of 'volume status'
Provide state of async tasks of all volumes in a new sub-command of 'volume s...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
:
Depends On:
Blocks: 1016993
  Show dependency treegraph
 
Reported: 2013-09-26 06:32 EDT by Krutika Dhananjay
Modified: 2014-04-17 07:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1016993 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2013-09-26 06:32:28 EDT
Description of problem:

The RHSC component needs a way of monitoring tasks using an inexpensive operation that can be consumed every 10 seconds to monitor all async tasks on all volumes in the cluster.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-09-26 07:00:48 EDT
REVIEW: http://review.gluster.org/6006 (cli,glusterd: Implement 'volume status tasks') posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2013-09-27 03:15:48 EDT
REVIEW: http://review.gluster.org/6006 (cli,glusterd: Implement 'volume status tasks') posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Anand Avati 2013-09-27 03:16:20 EDT
REVIEW: http://review.gluster.org/6006 (cli,glusterd: Implement 'volume status tasks') posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Anand Avati 2013-10-03 01:42:27 EDT
REVIEW: http://review.gluster.org/6006 (cli,glusterd: Implement 'volume status tasks') posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Anand Avati 2013-10-07 02:28:46 EDT
REVIEW: http://review.gluster.org/6006 (cli,glusterd: Implement 'volume status tasks') posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 6 Anand Avati 2013-10-09 02:13:22 EDT
COMMIT: http://review.gluster.org/6006 committed in master by Anand Avati (avati@redhat.com) 
------
commit e51ca3c1c991416895e1e8693f7c3e6332d57464
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Sep 24 17:01:46 2013 +0530

    cli,glusterd: Implement 'volume status tasks'
    
    oVirt's Gluster Integration needs an inexpensive command that can be
    executed every 10 seconds to monitor async tasks and their parameters,
    for all volumes.
    
    The solution involves adding a 'tasks' sub-command to 'volume status'
    to fetch only the async task IDs, type and other relevant parameters.
    Only the originator glusterd participates in this command as all the
    information needed is available on all the nodes. This is to make the
    command suitable for being executed every 10 seconds.
    
    Change-Id: I1edc607baf29b001a5585079dec681d7c641b3d1
    BUG: 1012346
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/6006
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 7 Niels de Vos 2014-04-17 07:48:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.