Bug 1012400 - Problems with activating nfs.enable-ino32
Problems with activating nfs.enable-ino32
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.4.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks: 1011694
  Show dependency treegraph
 
Reported: 2013-09-26 08:03 EDT by Nux
Modified: 2014-04-17 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 09:14:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nux 2013-09-26 08:03:36 EDT
Hello,

Activating  nfs.enable-ino32 seems to enable it globally, but it looks like the options is not saved across all volumes, just for the original volume.

@thanks to Kaushal on IRC for clearing this bug to me.
Comment 1 Anand Avati 2013-09-26 08:52:40 EDT
REVIEW: http://review.gluster.org/6007 (glusterd: Fix storing volumes on setting global opts) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)
Comment 2 Anand Avati 2013-09-29 20:05:01 EDT
COMMIT: http://review.gluster.org/6007 committed in master by Anand Avati (avati@redhat.com) 
------
commit 623d232d29bbed71349334988054a5bd205b1a39
Author: Kaushal M <kaushal@redhat.com>
Date:   Thu Sep 26 18:07:51 2013 +0530

    glusterd: Fix storing volumes on setting global opts
    
    Glusterd would not store all the volumes when a global options were set.
    When setting a global option, like 'nfs.*' options, glusterd used to
    modify the volinfo for all the volumes, but would store only the volinfo
    for the named volume. This lead to mismatch in the persisted and the
    in-memory representation of those volumes, which lead to problems like
    peers being rejected because of volume mismatches.
    
    Change-Id: I8bca10585e34b7135cb32af0055dbd462b3fb9b5
    BUG: 1012400
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/6007
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Anand Avati 2013-10-03 04:51:39 EDT
REVIEW: http://review.gluster.org/6029 (glusterd: Fix storing volumes on setting global opts) posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 4 Anand Avati 2013-10-16 07:22:13 EDT
REVIEW: http://review.gluster.org/6029 (glusterd: Fix storing volumes on setting global opts) posted (#2) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 5 Anand Avati 2013-10-24 16:31:56 EDT
COMMIT: http://review.gluster.org/6029 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 04181ad37d522d658373da03d99f32822d30bc88
Author: Kaushal M <kaushal@redhat.com>
Date:   Thu Sep 26 18:07:51 2013 +0530

    glusterd: Fix storing volumes on setting global opts
    
    Glusterd would not store all the volumes when a global options were set.
    When setting a global option, like 'nfs.*' options, glusterd used to
    modify the volinfo for all the volumes, but would store only the volinfo
    for the named volume. This lead to mismatch in the persisted and the
    in-memory representation of those volumes, which lead to problems like
    peers being rejected because of volume mismatches.
    
    BUG: 1012400
    Change-Id: I49903baaa4c93088d7c0d03553ccab37036b5426
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/6029
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 09:14:39 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.