Bug 1012433 - Avatar image caching is not asynchronous
Avatar image caching is not asynchronous
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: telepathy-glib (Show other bugs)
7.0
All All
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 09:15 EDT by Debarshi Ray
Modified: 2014-09-13 14:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:34:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 63402 None None None Never

  None (edit)
Description Debarshi Ray 2013-09-26 09:15:35 EDT
Due to the avatar image caching not being done asynchronously, gnome-shell can freeze if you add a chat account with lots and lots of contacts (eg., Google or Facebook).

This has been fixed upstream. We should backport it to RHEL7.
Comment 3 Martin 2014-03-31 12:00:40 EDT
Waiting for bug 1081520 to be fixed.
Comment 4 Vladimir Benes 2014-04-01 04:05:40 EDT
(In reply to Martin Holec from comment #3)
> Waiting for bug 1081520 to be fixed.

this is not a dependency, there is a workaround there in bug 1081520#c10 and this has nothing to do with that as can be verified using other accounts as well.
Comment 5 Martin 2014-04-01 12:08:54 EDT
I don't see any Facebook avatars in new (telepathy-glib-0.20.4-5.el7.x86_64), nor old (telepathy-glib-0.20.4-1.el7.x86_64) telepathy-glib. I see only Google Plus avatars.

I run: rm -r ~/.cache and added Facebook and Google accounts.
I haven't noticed any GS freeze in old or new version. Avatars just become gradually available in about a minute. I have tested GS Activities search and Empathy.
Comment 6 Ludek Smid 2014-06-13 08:34:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.