Bug 1012440 - Tag 1.0.1.Final-prod-ip6.0_ER4 of dtgov fails to build dtgov-distro due to incorrect order in the top level pom
Tag 1.0.1.Final-prod-ip6.0_ER4 of dtgov fails to build dtgov-distro due to in...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: ---
Assigned To: Eric Wittmann
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 09:24 EDT by George Varsamis
Modified: 2015-08-02 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Varsamis 2013-09-26 09:24:54 EDT
Description of problem:
dtgov-distro fails to build on this tag, as it has a dependency on dtgov-demos which is built afterwards, due to an incorrect order in the modules in the top level project pom.

This has been verified by Eric Wittman as it also happens in the community release as well.

Can you please fix and issue new tags for dtgov?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Eric Wittmann 2013-09-26 10:15:17 EDT
This should hopefully be fixed now.  Build issues can be tricky, and this one is new to me (including an assembly in another assembly).

I fixed community and then merged into the prod branch (dtgov).  New ER4 tag is:

1.0.1.Final-prod-ip6.0_ER4-2
Comment 2 George Varsamis 2013-09-26 12:32:21 EDT
I can confirm that this is fixed!
Comment 3 Stefan Bunciak 2013-10-02 06:56:02 EDT
Verified with FSW 6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.