Bug 1012441 - fedpkg tag-request broken: using undefined attributes of 'Commands' object
fedpkg tag-request broken: using undefined attributes of 'Commands' object
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: fedpkg (Show other bugs)
20
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Pavol Babinčák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 09:25 EDT by Michel Alexandre Salim
Modified: 2014-10-10 10:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-10 10:32:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2013-09-26 09:25:02 EDT
Description of problem:
When using fedpkg to submit a tag request, it first fails with

  Could not execute tagrequest: 'Commands' object has no attribute 'get'

which is due to the first line of the body of the tagrequest method definition in cli.py:

  self.cmd.tracbaseurl = self.cmd.get('fedpkg', 'tracbaseurl', raw=True)

After editing the file to manually set tracbaseurl to the value in fedpkg.conf, it then fails with:

  Could not request a tag release: 'Commands' object has no attribute 'override'

as soon as it tries processing the description (whether description text is passed interactively or through --desc)

Version-Release number of selected component (if applicable):
fedpkg-1.14-1.fc20.noarch
pyrpkg-1.19-2.fc20.noarch

How reproducible:
Always (also on RHEL 6)

Steps to Reproduce:
1. Clone a Fedora package with fedpkg
2. cd into the package directory
3. fedpkg tag-request

Actual results:
Error described above

Expected results:
Should just work

Additional info:
Comment 1 Pavol Babinčák 2014-10-10 10:32:17 EDT
fedpkg no longer has this option as we no longer use that work flow. The process is managed via blocker bugs now.

Note You need to log in before you can comment on or make changes to this bug.