Bug 1012483 - A null pointer exception is produced when the user uploads a .jar file without pom.xml as maven dependency
A null pointer exception is produced when the user uploads a .jar file withou...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low
: ER5
: 6.0.0
Assigned To: Walter Medvedeo
Ivo Bek
:
Depends On:
Blocks: 1019854
  Show dependency treegraph
 
Reported: 2013-09-26 10:38 EDT by Walter Medvedeo
Modified: 2014-08-06 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Medvedeo 2013-09-26 10:38:13 EDT
Description of problem:

A null pointer exception is produced when the user uploads a .jar file without pom.xml as maven dependency.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

The expected result is that the system shows three fields in order to let the user put manually the GAV for the given file.


Additional info:
Comment 2 Walter Medvedeo 2013-09-26 11:01:54 EDT
The problem was fixed in the following commits.
Now the user can upload a .jar file without the pom.xml to the maven local repository.

push master URL: http://github.com/droolsjbpm/guvnor/commit/fa5f64273

push 6.0.x URL: http://github.com/droolsjbpm/guvnor/commit/9a202143d
Comment 3 Jiri Locker 2013-11-18 09:41:05 EST
The commit is not reachable from ER4 tag in guvnor repository (sync.2013.10.09).
Comment 4 Ivo Bek 2014-01-14 07:50:57 EST
Verified in BPMS 6.0.0.ER7

Business central asks for package, artifact identifier, and version during the upload when pom.xml is missing.

Note You need to log in before you can comment on or make changes to this bug.