Bug 1012501 - Installed tab displayes incorrect number of non-covered products
Installed tab displayes incorrect number of non-covered products
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.5
Assigned To: John Sefler
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-26 10:53 EDT by Carter Kozak
Modified: 2013-11-21 16:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:30:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
behavior (36.52 KB, image/png)
2013-09-26 10:53 EDT, Carter Kozak
no flags Details
VERIFIED screenshots of the status of the number of installed products that do not have valid subscriptions (169.65 KB, image/png)
2013-10-04 11:52 EDT, John Sefler
no flags Details

  None (edit)
Description Carter Kozak 2013-09-26 10:53:49 EDT
Created attachment 803443 [details]
behavior

Description of problem:

When expired entitlements for un-covered products exist on a system, the product is double-counted.

How reproducible:
Add an entitlement for a product, change date on client and server to after it expires.
The number of uncovered products will be wrong.

Expected:
The number should reflect the number of red products on the system.
Comment 3 Carter Kozak 2013-09-26 15:49:54 EDT
commit c5a880e7736ede21d7533566e473572498c11c92
Author: ckozak <ckozak@redhat.com>
Date:   Thu Sep 26 10:43:43 2013 -0400

    1012501: Correct number of entitled products with expired ents
Comment 7 John Sefler 2013-10-04 11:52:06 EDT
Created attachment 807748 [details]
VERIFIED screenshots of the status of the number of installed products that do not have valid subscriptions

Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.9.8-1.el6.x86_64

Using these installed product certs from the candlepin TESTDATA,
[root@jsefler-6 ~]# ls /etc/pki/product/
1000000000000023.pem  100000000000002.pem  37070.pem  69.pem

I subscribed two products to a current subscription, attached one future subscription, and then took screenshots of the gui today, after the first two subscriptions expire, and after the future subscription expires.  The screenshot shows that the number of installed products that do not have valid subscriptions is correct for all three cases.

Moving to VERIFIED
Comment 8 errata-xmlrpc 2013-11-21 16:30:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.