Bug 1012507 - Fping issue on CentOS/yum installation
Fping issue on CentOS/yum installation
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: zabbix20 (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 10:57 EDT by s0r1n
Modified: 2013-09-30 05:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 04:58:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs while libssh2 removal failed (15.07 KB, text/plain)
2013-09-26 14:13 EDT, s0r1n
no flags Details

  None (edit)
Description s0r1n 2013-09-26 10:57:38 EDT
Description of problem:
Zabbix Server can reach the hosts with icmpping when the installation is made with rpm packages but it fails with yum packages.

Version-Release number of selected component (if applicable):
2.0.8-1

How reproducible:
Zabbix Server installation

Steps to Reproduce:
1.check if fping works for zabbixsrv (ex. fping -q -C3 134.34.200.1)
2.icmpping Items defined in Zabbix but returns 0 (host not reachable)
3.

Actual results:
fping fails because zabbix_server_<id>.pinger files are not created (by default in /tmp)

Expected results:
zabbix_server_<id>.pinger files to be created

Additional info:
https://support.zabbix.com/browse/ZBX-7054
Comment 1 Volker Fröhlich 2013-09-26 11:11:51 EDT
That's a short living file. It was probably removed by the time you looked there.

As I indicated on ZBX-7054, you have modified parts of your installation, mixed repositories and also set up some weird things. Sort that out first, particularly fping.
Comment 2 s0r1n 2013-09-26 14:10:49 EDT
I succeeded to reinstall iksemel from epel, but the pinger files won't be created

# yum list installed | grep zabbix
libssh2.x86_64        1.4.2-2.el6       @zabbix-non-supported
zabbix20.x86_64       2.0.8-1.el6       @epel
zabbix20-agent.x86_64 2.0.8-1.el6       @epel
zabbix20-server.x86_64
zabbix20-server-mysql.x86_64
zabbix20-web.noarch   2.0.8-1.el6       @epel
zabbix20-web-mysql.noarch
# yum list installed | grep fping
fping.x86_64          2.4b2-10.el6      @epel
# yum list installed | grep iksemel
iksemel.x86_64        1.4-2.el6         @epel

Next issue: I failed to remove libssh2 (see yum_remove_libssh2_130926.txt attached). Please let me know how to proceed further.
Comment 3 s0r1n 2013-09-26 14:13:28 EDT
Created attachment 803529 [details]
Logs while libssh2 removal failed
Comment 4 s0r1n 2013-09-29 08:42:47 EDT
I succeeded to remove libssh2 with --nodeps option, but since then is yum broken. Now I struggle to reinstall libssh2, could you provide any advice pls?

# rpm -e --nodeps libssh2
# rpm -qa | grep libssh2

# yum install libssh2
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   libssh2.so.1: cannot open shared object file: No such file or directory

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.6 (r266:84292, Jul 10 2013, 22:48:45)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-3)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://yum.baseurl.org/wiki/Faq
Comment 5 s0r1n 2013-09-29 09:10:56 EDT
Please ignore the previous comment, I fixed yum after libssh2 rpm installation:

# rpm -ivh http://mirror.centos.org/centos/6/os/x86_64/Packages/libssh2-1.4.2-1.el6.x86_64.rpm

Hence I checked there were no zabbix or fping packages installed, thus I proceed:

# yum install  zabbix20-server zabbix20-web zabbix20-agent zabbix20-get zabbix20-sender
# yum list installed | grep zabbix
zabbix20.x86_64       2.0.8-2.el6       @epel
zabbix20-agent.x86_64 2.0.8-2.el6       @epel
zabbix20-server.x86_64
zabbix20-server-mysql.x86_64
zabbix20-web.noarch   2.0.8-2.el6       @epel
zabbix20-web-mysql.noarch

fping is installed automatically during this operation, being a zabbix-server dependency:

# yum list installed | grep fping
fping.x86_64          2.4b2-10.el6      @epel

In conclusion I followed your suggestion, I re-installed all zabbix packages with yum, but the issue is still there, the pinger files are not generated.
Comment 6 s0r1n 2013-09-30 04:58:06 EDT
It seems fping has been blocked by selinux, the following logs drived me to this:

# tail -f /var/log/audit/audit.log |grep -i avc
type=AVC msg=audit(1380529975.252:86142): avc:  denied  { read } for  pid=25650 comm="fping" path="/tmp/zabbix_server_23950.pinger" dev=md2 ino=23986186 scontext=unconfined_u:system_r:ping_t:s0 tcontext=unconfined_u:object_r:initrc_tmp_t:s0 tclass=file
type=AVC msg=audit(1380529976.253:86143): avc:  denied  { read } for  pid=25661 comm="fping" path="/tmp/zabbix_server_23954.pinger" dev=md2 ino=23986186 scontext=unconfined_u:system_r:ping_t:s0 tcontext=unconfined_u:object_r:initrc_tmp_t:s0 tclass=file

After I disabled selinux, the pinger files were created and the issue disappeared:
# setenforce 0

I disabled selinux before installing the rpm packages for zabbix, but probably after a reboot it has been re-enabled and by mistake I suspected the yum packages to be guilty.
Comment 7 Volker Fröhlich 2013-09-30 05:31:39 EDT
Take a look at the README file in the base package concerning SELinux. By the way, the pinger files should now go to /var/lib/zabbixsrv/tmp. I think that won't trigger SELinux, but I'm not sure.

Note You need to log in before you can comment on or make changes to this bug.