Bug 1012514 - Don't install gpk-update-viewer by default
Don't install gpk-update-viewer by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-26 11:03 EDT by Allan Day
Modified: 2013-10-12 00:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: gnome-packagekit-3.10.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 00:34:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Day 2013-09-26 11:03:21 EDT
For Fedora 20 we have a shiny new Software app, which alerts you to software updates, and lets you view and install them. It consistently installs updates while "offline".

Currently, the old "Software Updates" (gpk-update-viewer) app is still installed in Fedora 20. This duplicates the functionality found in Software, and uses the old online install method. This creates an inconsistent experience, and the UI isn't as good.

We shouldn't show gpk-update-viewer in F20 by default. One way to deal with this would be to split it out into a subpackage.

I've filed a corresponding upstream bug, in case we want to fix the issue there instead: https://bugzilla.gnome.org/show_bug.cgi?id=708843
Comment 1 Adam Williamson 2013-10-11 07:21:55 EDT
Nominating this as a Beta blocker per criterion "Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image." - https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Update_notification

It's a bit of a stretch because current F20 _does_ notify the user, but it notifies the user _twice_, and one notification (as Allan notes) is hooked into a mechanism we don't want to be the default any more (and possibly don't want to block the release on), so that's a big problem.
Comment 2 Matthias Clasen 2013-10-11 15:57:24 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=470358
is a build that has gpk-update-viewer and gpk-application split out as subpackages.
Comment 3 Fedora Update System 2013-10-11 15:59:30 EDT
gnome-packagekit-3.10.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-packagekit-3.10.0-2.fc20
Comment 4 Fedora Update System 2013-10-12 00:34:21 EDT
gnome-packagekit-3.10.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.