Bug 1012604 - ksmtuned can’t handle libvirt WITHOUT set_process_name=1
ksmtuned can’t handle libvirt WITHOUT set_process_name=1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 13:37 EDT by Stefan Paletta
Modified: 2013-11-15 15:30 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-1.4.2-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1027420 (view as bug list)
Environment:
Last Closed: 2013-11-15 15:30:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Paletta 2013-09-26 13:37:19 EDT
Description of problem:
This time around ksmtuned doesn’t find qemu processes when set_process_name in /etc/libvirt/qemu.conf is NOT changed from the default 0.

This is because qemu was recently changed to incorporate qemu-kvm, and the qemu-kvm program now just exec-s the respective qemu-system-* binary with the right arguments. The process list will therefore show only qemu-system-* processes as representing the VMs.

With ksmtuned looking for processes of either "qemu-kvm" or "qemu:something" (with "something" being the respective VM name, as it happens when set_process_name=1), these qemu-system-* processes will slip through.

Version of selected components:
ksm-1.4.2-9.fc19.x86_64
qemu-system-x86-1.4.2-9.fc19.x86_64

Additional info:
There doesn’t seem to exist a functional specification as to which qemu processes ksmtuned should take into account, i.e. only those started by libvirt or also those started by other means, and by what criteria is should apply to tell them apart.

However, to find qemu-system.* processes in addition to all those that were previously found, the regexp on line 74 of ksmtuned can simply be changed to read ^qemu(-(kvm|system-.+)|:.{1,11})$
Comment 1 Cole Robinson 2013-10-31 16:24:25 EDT
Thanks for the suggestion and bug report, moving to POST since there's a fix
Comment 2 Fedora Update System 2013-11-05 20:26:55 EST
qemu-1.4.2-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qemu-1.4.2-13.fc19
Comment 3 Fedora Update System 2013-11-06 22:39:14 EST
Package qemu-1.4.2-13.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.4.2-13.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20824/qemu-1.4.2-13.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-15 15:30:32 EST
qemu-1.4.2-13.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.