Bug 1012610 - ksmtuned committed_memory() still returns "", not 0, when no qemu running
ksmtuned committed_memory() still returns "", not 0, when no qemu running
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 13:52 EDT by Stefan Paletta
Modified: 2013-11-15 15:30 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-1.4.2-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1027418 (view as bug list)
Environment:
Last Closed: 2013-11-15 15:30:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Paletta 2013-09-26 13:52:31 EDT
Description of problem:
Despite the efforts in #609016 and #902688, this is still / again broken.

Version of selected components:
ksm-1.4.2-9.fc19.x86_64

How to reproduce:
Understand committed_memory() in ksmtuned, then:

$ < /dev/null awk '{ sum += $1 }; END { print sum }'

$ 

Additional info:
Please change the awk clause in line 77 of ksmtuned to the obvious and correct solution: 'END { print 0+sum }':

$ < /dev/null awk '{ sum += $1 }; END { print 0+sum }'
0
$
Comment 1 Cole Robinson 2013-10-31 16:24:12 EDT
Thanks for the suggestion, moving to POST since there's a fix
Comment 2 Fedora Update System 2013-11-05 20:27:03 EST
qemu-1.4.2-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qemu-1.4.2-13.fc19
Comment 3 Fedora Update System 2013-11-06 22:39:22 EST
Package qemu-1.4.2-13.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.4.2-13.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20824/qemu-1.4.2-13.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-15 15:30:41 EST
qemu-1.4.2-13.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.