Bug 1012663 - [RFE] WebAdmin: provide more space on the sub-tabs
Summary: [RFE] WebAdmin: provide more space on the sub-tabs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
: 962879 (view as bug list)
Depends On: ovirt_ui_redesign
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-26 20:17 UTC by mrao
Modified: 2019-05-16 13:06 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:36:09 UTC
oVirt Team: UX
Target Upstream Version:
sherold: Triaged+
lsvaty: testing_plan_complete-


Attachments (Terms of Use)
problem and solution of lower pane (82.52 KB, image/jpeg)
2013-11-10 09:51 UTC, Eldan Hildesheim
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:38:11 UTC

Description mrao 2013-09-26 20:17:51 UTC
Description of problem:

When VM details are being viewed, 3 panes become available – top list, bottom details and the events panel ( bottom tab) and there is no way to maximize any of these panes effectively. Customer wants to reclaim real estate and have the ability to make any one of these full screen with a click – pop-out panels. The pop-out panels can be read-only. Popping out Events is desired especially.

This is needed because user is Running out of real estate when single screen presents too many levels of information

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 mrao 2013-09-26 20:21:02 UTC
Another use case that points to the need to maximize certain sections of the console - User would like to have the ability to close down the detail sub tabs at the bottom of a list when a row is selected above. Today, the only way to do that is to go to a different tab and return. “We do this a 100 times a day and it gets annoying”

Comment 4 mrao 2013-09-26 20:26:54 UTC
Related bug pointing to the need of the user to adjust the distribution of screen real estate - Bug 999713

Comment 7 Einav Cohen 2013-11-08 21:43:42 UTC
*** Bug 962879 has been marked as a duplicate of this bug. ***

Comment 9 Eldan Hildesheim 2013-11-10 09:48:46 UTC
We should probably open a new bug on the following issue but since it's the same view I'll describe the problem and solution here. We can then open a new bug for it.
The lower pane description looks awful and is not readable anymore.
We should seriously consider changing the alignments of name to the right and changing the colours of the values.

Take a look at my sketch.
Eldan

Comment 10 Eldan Hildesheim 2013-11-10 09:51:55 UTC
Created attachment 822043 [details]
problem and solution of lower pane

Comment 13 Oved Ourfali 2017-05-15 06:53:57 UTC
In 4.2 ui re-design, we'll have the object details in a new page, resulting in much more space, so that will no longer be needed.
Adding proper dependency.

This won't support popping out the details to a new dialog, but it will give more space.

Comment 15 Lucie Leistnerova 2017-11-03 12:23:14 UTC
Tasks, Events and details also are now opened in whole page view.

verified in ovirt-engine-4.2.0-0.4.master.el7.noarch

Comment 16 RHV bug bot 2017-12-06 16:17:41 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 17 RHV bug bot 2017-12-12 21:16:09 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 20 errata-xmlrpc 2018-05-15 17:36:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 21 Franta Kust 2019-05-16 13:06:26 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.