Bug 1012689 - Please build libseccomp's Python bindings
Please build libseccomp's Python bindings
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: libseccomp (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Moore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 17:49 EDT by Andy Lutomirski
Modified: 2013-12-17 15:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 14:48:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Lutomirski 2013-09-26 17:49:21 EDT
libseccomp 2.1.0 added Python bindings, but the Fedora package doesn't seem to build them.
Comment 1 Paul Moore 2013-09-26 17:56:06 EDT
While the Python bindings do exist in libseccomp 2.1.0, they are intentionally disabled (support is removed from ./configure) as they are not yet supported.

Do you have a Python application that can make use of libseccomp?
Comment 2 Andy Lutomirski 2013-09-26 18:02:44 EDT
I'm writing one.  It's a simple web server that will sandbox itself after loading but before accepting any connections.
Comment 3 Paul Moore 2013-09-26 18:17:06 EDT
Please keep the upstream libseccomp developers aware of your progress, one of the reasons why the Python bindings are not yet supported is the lack of experience with any Python apps using libseccomp.  Your experience could help push that forward.
Comment 4 Andy Lutomirski 2013-09-26 21:20:06 EDT
Will do, but don't hold your breath...

This stuff is likely to be a bit messy, because it's perfectly valid for Python to issue unexpected syscalls.  I'll probably end up forcing some combination of ENOSYS returns and SIGSYS.
Comment 5 Cole Robinson 2013-12-17 14:48:02 EST
Since the python bindings are still experimental, things are basically functioning as intended, so there isn't much use in keeping this bug open.

Note You need to log in before you can comment on or make changes to this bug.