Bug 1012699 - DSUtil.pm needs to check $res variable
DSUtil.pm needs to check $res variable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.5
Assigned To: Rich Megginson
Sankar Ramalingam
: Reopened
Depends On:
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-09-26 18:52 EDT by Nathanael Noblet
Modified: 2014-10-14 03:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Cause: Supplying an invalid hostname to the server install script Consequence: A vague error message is reported Fix: Return a proper error message when the hostname is invalid Result: A clear error message is returned when then setup script comes across an error with the hostname.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:50:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes issue (1.11 KB, patch)
2013-09-26 18:52 EDT, Nathanael Noblet
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1385 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2014-10-13 21:27:42 EDT

  None (edit)
Description Nathanael Noblet 2013-09-26 18:52:01 EDT
Created attachment 803632 [details]
Patch that fixes issue

Description of problem:
I'm trying to setup a 389 server. It is done automatically via the kolab-setup which intern is calling the 389 setup script. It fails because DSUtil.pm doesn't check if $res exists before calling functions on it.

I get the following error:

Can't call method "getText" on an undefined value at /usr/lib64/dirsrv/perl/DSUtil.pm line 259.

Version-Release number of selected component (if applicable):
389-ds-base-1.2.11.15-22.el6_4.x86_64

How reproducible:
Always

Obviously this is fixed in a newer version of 389 - however the EPEL package doesn't seem to be getting updated.

The attached patch fixes the issue
Comment 1 Rich Megginson 2013-10-01 16:29:30 EDT
Upstream ticket:
https://fedorahosted.org/389/ticket/422
Comment 2 Nathan Kinder 2013-12-18 14:52:21 EST
This was fixed in 389-ds-base-1.3.1.0-1.
Comment 3 Nathanael Noblet 2013-12-18 16:31:05 EST
I realize it was fixed in newer versions of 389-ds. However the version provided to epel is 1.2.2. So there needs to be a patch for epel or epel needs an updated version.


koji latest-pkg dist-6E-epel 389-ds

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
389-ds-1.2.2-1.el6                        dist-6E-epel          rmeggins
Comment 4 Rich Megginson 2013-12-18 18:45:27 EST
Wrong package - you want 389-ds-base - 389-ds is just a "meta" package wrapper around the other components

Also note that 389-ds-base is not technically in EPEL6 since it is included in the base RHEL6 (or whatever EL6 distro you are using) - see http://port389.org/wiki/Download

This was fixed in 389-ds-base-1.2.11.23.
Comment 5 Nathanael Noblet 2014-01-08 14:46:28 EST
So I've re-assigned this to RHEL 6. Currently 389-ds-base has the bug listed above...
Comment 7 Noriko Hosoi 2014-01-08 18:49:35 EST
Fixed in upstream.  Changing the status to POST.
Comment 9 mreynolds 2014-06-20 09:41:57 EDT
Verification steps:

[1]  Run setup-ds.pl
[2]  Provide an invalid hostname during the install (bogus.bogus.bogus.com)
[3]  The error should not be (Can't call method "getText"), but it should instead mention the invalid hostname,
Comment 11 errata-xmlrpc 2014-10-14 03:50:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.