Bug 101271 - Installer offers to make boot diskette; machine has no floppy drive
Summary: Installer offers to make boot diskette; machine has no floppy drive
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 15:30 UTC by Mike Shaver
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 20:13:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Shaver 2003-07-30 15:30:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030523

Description of problem:
(I have no mouth, but I must...nevermind.)

I didn't try to create a boot disk, because I didn't really want to botch my
install at that point, but if I get a chance to reinstall I will.

Version-Release number of selected component (if applicable):
Severn beta 1

How reproducible:
Always

Steps to Reproduce:
1. Install on a machine with no floppy drive

Actual Results:  It asked if I wanted to make a boot floppy.

Expected Results:  It shouldn't have asked.

Comment 1 Michael Fulbright 2003-07-30 16:42:25 UTC
What is the model of hardware? 

Comment 2 Mike Shaver 2003-07-30 16:48:08 UTC
Dual Athlon, 1G RAM, Tyan S2466, TNT2 video.

Bag of parts Mk 1, really.

Do you want some lspci or other output?

Comment 3 Mike McLean 2003-07-30 18:01:37 UTC
I can't seem to reproduce here.  Is it possible that your BIOS is configured to
think there is a floppy attached?

Also, what install method did you use?

Comment 4 Bill Nottingham 2003-07-30 18:26:52 UTC
Postinstall, what's the output of 'kudzu -p -b misc'? Also do you have any
removable drives (usb, firewire, etc.)?

Comment 5 Mike Shaver 2003-07-30 19:04:56 UTC
[root@localhost root]# kudzu -p -b misc
[root@localhost root]# 

No removable media other than the CD, though the motherboard does support USB
(no 1394).

Last I checked, the BIOS doesn't have any mention of the floppy, but I'll try to
get a reboot in today to find out for certain.

Comment 6 Mike Shaver 2003-07-30 19:06:55 UTC
Forgot to answer the other of Mike's questions: I used the HTTP install (newly
graphical!).

Comment 7 Michael Fulbright 2003-08-11 20:13:29 UTC
Some hardware appears to have a floppy controller with floppy even though it is
not present.  I do not know that we can catch all these situations. We appear to
handle the case of a legacy free machine with only USB connections that does not
have a floppy drive attached correctly.


Note You need to log in before you can comment on or make changes to this bug.