Bug 1012718 - F20 Alpha (Mate Live) won't suspend on Acer Aspire One D255E Netbook
F20 Alpha (Mate Live) won't suspend on Acer Aspire One D255E Netbook
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-power-manager (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 22:15 EDT by fred smith
Modified: 2013-10-09 21:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-power-manager-1.6.2-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:17:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred smith 2013-09-26 22:15:22 EDT
Description of problem:
Testing F20 Alpha LIVE CD, MATE edition. won't suspend when lid closed, power manager is set to suspend on lid closed. Also, wont' suspend when suspend button (FN-F4) is pressed. Produces popup error: "Failed to suspend" "Computer failed to suspend." "Failure was reported as cannot suspend."

The panel applets for logout and shutdown do not show either suspend or hibernate as options, but they DO show them in F19.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.set power manager to suspend on lid close
2.close lid
3.wait.
4. getting tired of waiting after a minute or so, open lid and find the above-mentioned error message.

Actual results:
won't suspend

Expected results:
suspend

Additional info:
Comment 1 fred smith 2013-09-26 22:16:55 EDT
I failed to mention: while it is a 64-bit processor, I'm testing the 32-bit Mate Live ISO.

in case it matters, I used 'dd' to put it on a usb stick, from which it boots fine.
Comment 2 Dan Mashal 2013-09-27 03:35:22 EDT
Did you create a swap partition?
Comment 3 Wolfgang Ulbrich 2013-09-27 07:28:39 EDT
Did you installed fedora on disk or you're using the livecd?
Can you suspend with one of those commands?

gdbus call --system --dest org.freedesktop.login1 --object-path /org/freedesktop/login1 --method org.freedesktop.login1.Manager.Suspend true

dbus-send --system --print-reply --dest="org.freedesktop.login1" /org/freedesktop/login1 org.freedesktop.login1.Manager.Suspend boolean:true

@ Dan
a swap is only needed for hibernate.
Comment 4 fred smith 2013-09-27 13:16:51 EDT
@wolfgang, et al:
Yes, both of those commands cause it to suspend.
Comment 5 Wolfgang Ulbrich 2013-09-27 22:46:25 EDT
I'm pretty shure if you install f20 on disk the issue will gone, don't forget to run 'yum update' after installation.
Some important updates aren't include the livecd because of the alpha freeze.
Comment 6 fred smith 2013-09-28 21:30:39 EDT
OK, I've done an install from the LIVE image onto a USB hard drive (don't want to mess up the F19 already installed).

Suspend does NOT work when the lid is closed even though the power manager is set to suspend upon lid close. I get the same error popup as described earlier.

it DOES work in certain other circumstances: if I install the shutdown applet in the top panel, then click suspend from there it works.

if power manager is set to "ASK" for a press of the power button, when it asks I can choose "suspend" and it works.
Comment 7 fred smith 2013-09-28 21:31:51 EDT
sorry about my last comment (#6), in which I neglected to say that I did to a full update before doing t hose tests.
Comment 8 Wolfgang Ulbrich 2013-09-29 16:27:57 EDT
I can confirm this issue on my notebook too, fixed build comming soon.
Comment 9 Fedora Update System 2013-09-29 20:58:13 EDT
mate-power-manager-1.6.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-power-manager-1.6.2-4.fc19
Comment 10 Fedora Update System 2013-09-29 20:58:24 EDT
mate-power-manager-1.6.2-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mate-power-manager-1.6.2-4.fc20
Comment 11 Fedora Update System 2013-09-29 20:58:37 EDT
mate-power-manager-1.6.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-power-manager-1.6.2-4.fc18
Comment 12 Fedora Update System 2013-09-30 21:53:05 EDT
Package mate-power-manager-1.6.2-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-power-manager-1.6.2-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17975/mate-power-manager-1.6.2-4.fc18
then log in and leave karma (feedback).
Comment 13 fred smith 2013-10-01 21:32:49 EDT
I just did a full update (unfortunately, I should have done just the power manager, but I wasn't thinking), and after a reboot the system DOES suspend when the lid closes, and it wakes right back up after a keypress.

however,... the power manager app no longer works. if I click on it I don't
see anything. if I run it from a commandline, after a significant pause I get this:

$ mate-power-preferences

(mate-power-preferences:10937): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


Now, I can't tell if it's due to some bug in powermanager, or some bad interaction with some other updated package, since I updated everything.
Sorry!
Comment 14 Wolfgang Ulbrich 2013-10-02 04:53:00 EDT
This must be to someting other related. In my f20 boxes i can start mate-power-preferences without any problem.
Comment 15 fred smith 2013-10-08 23:56:09 EDT
Using F20 Beta TC2 MATE LIVE I find the original problem still exists. Apparently the various fixed/updated packages that one obtained on the alpha by doing "yum update" did not make it into the BETA TC2 spin.
Comment 16 Fedora Update System 2013-10-09 10:17:01 EDT
mate-power-manager-1.6.2-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-10-09 20:54:23 EDT
mate-power-manager-1.6.2-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-10-09 21:03:50 EDT
mate-power-manager-1.6.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.