Bug 1012740 - (CVE-2013-1739) CVE-2013-1739 nss: Avoid uninitialized data read in the event of a decryption failure
CVE-2013-1739 nss: Avoid uninitialized data read in the event of a decryption...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20131017,repor...
: Security
Depends On: 1020123 1032466 1032470
Blocks: 1012742 1030811
  Show dependency treegraph
 
Reported: 2013-09-27 00:46 EDT by Huzaifa S. Sidhpurwala
Modified: 2015-10-15 14:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: nss-3.15.3-2.el6_5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2013-09-27 00:46:11 EDT
A flaw was found in the way nss read uninitialized data, when there was a decryption failure. A remote attacker could use this flaw to cause denial of service for applications linked with the nss library (application crash)
The vulnerable code was added in NSS 3.14.3 to fix the lucky-13 issue (CVE-2013-1620). This issue is resolved in nss-3.15.2

References:

https://developer.mozilla.org/en-US/docs/NSS/NSS_3.15.2_release_notes
https://bugzilla.mozilla.org/show_bug.cgi?id=894370 (currently closed)
patch: https://hg.mozilla.org/projects/nss/rev/56436aa3463f
Comment 10 Huzaifa S. Sidhpurwala 2013-10-17 00:57:47 EDT
Statement:

This issue affects the version of nss as shipped with Red Hat Enterprise Linux 5 and 6. The Red Hat Security Response Team has rated this issue as having moderate security impact, a future update may address this flaw.
Comment 11 Huzaifa S. Sidhpurwala 2013-10-17 00:58:50 EDT
This flaw is resolved in the following versions of nss in Fedora:

Fedora-18: http://koji.fedoraproject.org/packages/nss/3.15.2/1.fc18
Fedora-19: http://koji.fedoraproject.org/packages/nss/3.15.2/1.fc19
Fedora-Rawhide: http://koji.fedoraproject.org/packages/nss/3.15.2/1.fc20
Comment 16 Tomas Hoger 2013-12-03 04:45:19 EST
(In reply to Huzaifa S. Sidhpurwala from comment #0)
> The vulnerable code was added in NSS 3.14.3 to fix the lucky-13 issue
> (CVE-2013-1620).

CVE-2013-1620 was tracked via bug 908234.  Relevant errata released to address that issue in Red Hat Enterprise Linux 5 and 6 are:

https://rhn.redhat.com/errata/RHSA-2013-1135.html
https://rhn.redhat.com/errata/RHSA-2013-1144.html

Previous nss packages versions were not affected.
Comment 17 errata-xmlrpc 2013-12-05 11:16:41 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2013:1791 https://rhn.redhat.com/errata/RHSA-2013-1791.html
Comment 18 errata-xmlrpc 2013-12-12 14:03:37 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:1829 https://rhn.redhat.com/errata/RHSA-2013-1829.html

Note You need to log in before you can comment on or make changes to this bug.