Bug 1012757 - Can not restart after force-stop the app for nodejs-0.6 and nodejs-0.10
Can not restart after force-stop the app for nodejs-0.6 and nodejs-0.10
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 01:40 EDT by Yan Du
Modified: 2015-05-14 19:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:32:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
development.log (140.75 KB, text/plain)
2013-09-27 01:41 EDT, Yan Du
no flags Details
platform log (113.26 KB, text/plain)
2013-09-27 01:41 EDT, Yan Du
no flags Details
mcollective log (349.02 KB, text/plain)
2013-09-27 01:42 EDT, Yan Du
no flags Details

  None (edit)
Description Yan Du 2013-09-27 01:40:03 EDT
Description of problem:
Can not restart after force-stop the app for nodejs-0.6 and nodejs-0.10


Version-Release number of selected component (if applicable):
INT(devenv_3835)
devenv_3836


How reproducible:
Always


Steps to Reproduce:

1. Create a nodejs app (nodejs-0.6 or nodje-0.10)
#rhc app create n6 nodejs-0.6
2. rhc app-force-stop n6
3. rhc app restart n6



Actual results:

root@openshift-ubuntu:~/test# rhc app-force-stop n6
RESULT:
n6 force stopped

root@openshift-ubuntu:~/test# rhc app restart n6
Unable to complete the requested operation due to: Failed to correctly execute all parallel
operations.
Reference ID: 01c3ed36f6251fa01e002a024c9f5e40


platform.log/development.log/ruby193-mcollective.log has attached.



Expected results:
should restart app normally after force-stop


Additional info:
app can start after force stop. just restart app can occur the issue
Comment 1 Yan Du 2013-09-27 01:41:12 EDT
Created attachment 803732 [details]
development.log
Comment 2 Yan Du 2013-09-27 01:41:53 EDT
Created attachment 803733 [details]
platform log
Comment 3 Yan Du 2013-09-27 01:42:32 EDT
Created attachment 803734 [details]
mcollective log
Comment 4 openshift-github-bot 2013-10-01 17:05:10 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/fe4b4d708bf48abc6d2961502fee16da5a66d779
Bug 1012757 - Make sure the restart will succeed for force-stopped Node cartridge
Comment 5 Peter Ruan 2013-10-02 19:04:10 EDT
verified with devenv_3851
[peter@unused-16-138 <DEV> ~]# rhc app restart n6
RESULT:
n6 restarted

Note You need to log in before you can comment on or make changes to this bug.