Bug 1012763 - Twitter bootstrap CSS makes <code> elements pink in DocBuilder
Twitter bootstrap CSS makes <code> elements pink in DocBuilder
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: DocBook-builder (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.8
Assigned To: Matthew Casperson
:
Depends On: 1050740
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 01:50 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-13 17:10:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-09-27 01:50:01 EDT
Need to use the non-minified CSS and remove this rule.
Comment 1 Matthew Casperson 2014-06-25 18:09:48 EDT
Fixed and deployed to docbuilder.

This was already commented out, but I set the background-color and color values in pressgang.css to override anything in the bootstrap css file.
Comment 2 Lee Newson 2014-06-25 19:48:04 EDT
Failing this as the change applied only affects elements that use the "code" class. The problem here is that the <code> element is having the bootstrap style applied.
Comment 3 Matthew Casperson 2014-06-25 22:40:05 EDT
Changed rule to match the element,  not the class.

Use the presszilla_fixes branch to test.
Comment 4 Lee Newson 2014-07-07 20:30:51 EDT
Verified that this works for the current brands used. However if a brand were to set something like:

code {
    color: blue;
}

then it will not be applied due to the important inherit rule. Anyways since we have opened BZ#1113314 to deal with this properly I'm happy to move this to VERIFIED as an interim solution. I'll leave this decision up to Matt though in-case he want's to change it.

Note You need to log in before you can comment on or make changes to this bug.